Stuck behind my pet. No way out

Game mode: [Online private]
Type of issue: [Bug | Misc]
Server type: [PvE]
Region: [Canada / North America]

I went to asgard to kill thralls with my new pet… a greater saber tooth. We didn’t get far, after clearing the entrance I went into the first little hut on the right and the saber stopped just inside the door. he couldn’t come in and I was stuck in the room. I tried to pick it up to move it and it says ‘no thralls allowed here’ so I could not place it down… or walk through it. I could not tell it to stop following as well. In the end… removing my bracelet and dying was the only way out of that room.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Go to asgard (or probably any NPC place with structures)
  2. Have pet (greater saber) on follow
  3. enter a structure
  4. sometimes suicide is the answer.

You will pick it up as that would be logic- just move it a bit and walk past it.

  • “thralls are not allowed here”

"Aw wait yes darn. :grimacing:

And then your stuck with a thrall in your hands and the darn thing still in the door, you have to walk out of claimed lands and place it to get rid of the darn thing.

At least suicide is painless in CE

Funcom should provide us the option to tell our follower “get behind me” so we could have a way out in these kind of scenarios.

Can’t you just use the move option, get out of the hut and cancel?

You’ll be out of the hut, and the pet will be in his original spot.

wouldn´t your sabertooth have attacked the thralls once they respawn and moved out of the doorway? you could have just waited a few mins instead if I´m correct

Yeah, happened to me too… i had to sacrifice the animal

The kicking would be hilarious.:hugs:

Like a "fck you"growl and take an alternative position.
Another kick will send to a new atlternative position exept the two before.
Case fixed.

Well more like a bandaid, but hey, still works.

a Priory i would say the game has to identify the sitation
“No room for char to pass pet” and act by moving the pet.

Wich i think will be the used solution eventually.
The moving is already implemented imo, they have to connect the trigger to this specific situation.

I think the way out of this is to click “stop following” it will go back to the last place you “moved” it to.

My bad I didn’t see that part of the comment for some reason.

Ya I tried stop following but it gave an error like ‘thralls not allowed here’.

i had this with a group of thralls the other day who came up behind me, (to defend against an NPC thrall), but they trapped me near a fluid press.
If a way to issue commands (like “Clear a Path” or “Step Back” or something becomes available, that could help) - otherwise maybe that PickupPlus mod could help in the meantime.

actually, getting trapped by one of your thralls, wearing a Gandalf Wizard’s hat could be funny though… “You Shall Not Pass” :slight_smile:

Not saying you are wrong just for the dialog. :grinning:

Should this be possible?

As the last “Move” position - whereto the thrall will return (Or am i missing something), can logically NOT be a “Thralls are not allowed here” position ?

I think what was happening there… is that when you tell a thrall to stop following… it stands on that spot in sentry mode. And since I was in a location where you are not allowed to place thralls it would not allow that condition to happen so it refused to come off follow.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.