T3 corner stairs still not placing correctly

Game mode: [Enter game mode here: Online private
Type of issue: Bug
Server type: [Enter one of the following: | PvE]
Region: North America

Since I didn’t see this on the Trello board or in any recent posts, I’ll see it can make the list. Stair corners still aren’t snapping, mainly T3 but Aquilonian in this case. The bottom will snap to a foundation, but not the top if I’m placing on the ground. T2 corners don’t have this problem.

EDIT: I tried all t3 stair corners and they all have the same problem.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:


Yup, I can confirm this issue, which has been around for several weeks now. I’m on an Official EU PvE server.

Grrr, that stupid freaken piece of crap bug (you have no idea how much bloody time I’ve spent in the dev kit on this one lol). I’ll have to dig around my old notes on it.

In any case, the temporary workaround is to try and hide a set of foundations below the stairs you’ve got going. If they can build off of a foundation, then they work fine.

They need something to snap to at the bottom. Pretty sure that all of the stairs do not have snap points in the middle.

1 Like

True, but dangerous, as you might end up unable to “target” that foundation to remove it, should you wish to do so at a later date. I have that problem in a few locations around my main base now.

1 Like

I placed these out of sequence in order to thread the conversation.

On PVP servers you move so fast to find things, in the immediacy it’s like fishing for a solution so they call it “casting down” in order to place a below-surface foundation that can then be exploited.* I think this has to do with the (former) flexibility of the mesh. @Cauthey and I hunted down some fools who cast down far enough to build into one of the Jungle temple areas. Functionally, your brick becomes part of the mesh and Set or high water won’t touch it. Mitra might, but it’s a toss-up.

In other words, cast errant foundations at your peril because they’re patching it. A better solution is to fence-raise the immediate area (1/3 block elevation), drop a foundation at 1/3 increased elevation, then delete that foundation. You will generally be able to place any shape there, including corner stairs.

Separately, try placing a corner ramp there instead. This works almost always. After the server reboots and the corner ramp remains, try deleting it and immediately placing a stair.

* purposefully vague

Hey everybody,

I’ve sent your feedback to our team and they’ll look into it. Thanks for your report!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.