They Are Called Darkness blue moubtain

i destroy the akab royal burrow 8 times and kill the queen 8 time and the mission not completed probably another bug

It worked fine when i did it a week ago =/


Worked fine for me just now.


You may want to provide more info about what happened. Mission tier. Screenshot could definitely help. Or even short video if you don’t mind.


i see thr soluce of this quest i am in tier one and in the soluce the desruction of the akabburrow is tier 2 i will restart the questagain to see

i see the problem in tier 1 youmust kill a simple burrow and tier 2 a queen burowand i dont kill the simple but begin to the queen and the quest not validate no bug

I notice you’re having some problems (“bugs”) with the game. If you ever need help, and you want to be sure something isn’t a bug before posting here, you can always try using “Mission Hints” category in chat. You might get help right away from other players.

1 Like

thank in the game i make all quest


In my experience the burrow to destroy is marked wrongly, find the right one and all was well.

Was having this issue also. What I found was for Tier 2, if your char is OP and can one-shot the burrow it doesn’t trigger properly. Need to use a weaker weapon or basic attack to put multiple hits in.