Thrall disappears in Dungeon

Game mode: Online private
Type of issue: Bug
Server type: PvP
Region: America

I enter a dungeon with Thrall. If I go through an area the thrall can’t easily follow (having to swim underwater or jump for example, like in Sunken City), the thrall should teleport to me afterwards (and usually does). However twice now, once in the Dregs and once in Sunken city, the thrall has failed to teleport. It vanishes, then is listed as ‘scouting’, then after a while ‘returning home’ and finally ‘guarding’.

So at that point it’s game over, the dungeon becomes unplayable and I have to give up and go home. Because the core mechanism of being able to bring a thrall into a dungeon, which the game makes necessary, is unreliable and broken.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Bring thrall follower to sunken city (or other dungeons with swimming)
  2. Go through until you have to jump and/or swim
  3. Thrall will disappear (maybe, maybe not, happens randomly)
  4. Realise you now have to leave dungeon with nothing and run home

Same thing happens to me. My thrall only helps me on the island with the cultists.
Maybe having a thrall companion in the dungeon is considered cheesing?

1 Like

No way. If bringing a thrall, one of the core game mechanics, to a hard part of the game is ‘cheesing’ then Funcom have lost their minds.

It’s definitely a bug, because it only happens half the time.


I hope you are right. It happens to me 100% of the time, swam back to the island, killed the cultists again, did not jump but swam to a dungeon from the beach (found some chests near the beach).
If using E-key in an under water dungeon my char drinks, so no way to command your thrall.

1 Like

Maybe it is intended for certain dungeon rooms, that you’re supposed to enter alone.

But if so, the game should let you know so you don’t think it’s a bug, and the thrall should actually wait for you outside, not lose you and go home.

1 Like

Since there has been no response to this thread, sort of like “Devs are looking into it”. I assume the 1% of the 1% has deemed, this Under water dungeon to be too easy, or the rewards to great.
The response from the 1% of the 1% would be “just farm champions armor”, which ofc you can’t get because the dungeon is too hard, because you can’t get those fish to get a bit more strenght, because the under water dungeon is too hard… (It’s conspiratorial I know, but the 1% of the 1% already got that armor and wants the game to be harder) (also want to keep the thread allive, I admit)

Nah, it’s a bug. Why else would it happen randomly, and why wouldn’t the thrall wait outside?

Is there any response to this? I see most bug reports get a response within a few hours. It’s been reported by other players too.

1 Like

Thalls/Pets disapear everywhere
since the patch they are like ghost to the environment, they run through ressources,but get stuck there, they run into the world, and get stuck there, they fall in the ground, and get stuck, and since there was a change to the follow/teleport behavior, they no longer teleport back to the player when the player is too far away.
Basicaly, Funcom f…up this patch without proper testing, no idea how this patch could ever get live. Just lost 5th thrall (this time level 20) to this “bug” (actualy it is not a bug, its a feature, lol). Right now CE is unplayable like this. Doubt it Funcom will bring a patch in the near future.


As a server admin I’ve had to retrieve Thralls consistently for players from The Dregs. When I get there I flick admin ghost mode on and then search through the floors and rocks and there they are.

Fortunately I’ve got LBPR mod and Mod control panel installed, flipped “Allow building anywhere” on to allow placemnt of Thralls in dungeons (guard mode etc), placed thrall next to player, resolved.

It will happen consistently in these dungeons though, seems like they revised the teleport mechanic and effectively highlighted how bad the pathing of thralls past obstacles is, making the thralls useless.

I’ve had to advise all players not to use Thralls in the Dregs until further notice. It’s pointless and bloody hard finding them as an admin when they get lost. Rescue function is useless, the 10 minute timer resets constantly as it believes the mob is being attacked (not sure why, mob was underwater it seems and not near any enemies).

Rescue tool needs to be improved for PVE servers, personally I’d rather have the option to enable unlimited rescues (regardless of in combat or not, no equipment loss on Thralls until such time that Thralls can be improved. Sure it can be exploited but it’s a PVE server so it’s their experience they are damaging, not someone else’s.

Since this Thrall issue happened before the recent Thrall updates (Thralls fell through in all sorts of places and would not auto return, even the middle of the Savannah type areas) I don’t expect this to be fixed anytime soon.

1 Like

Hey there,

We got some reports recently about bodies of water causing issues with followers. Our team is looking into that feedback.
Apologies for the frustration.

1 Like

Same applies if you are about to climb in the mounds of the dead to where the bearer and couple of fighters and a taskmaster sit.
And under the black galleon to get the special chest.

*I see Ignasis already answered this.

** I have an outpost in front of The frozen slopes and every time I set my thrall to guard that small house he/she disappears and times later she/he’s back at my main base.

I can confirm this.
I just “lost” a thrall in the sunken city.

I was swimming to the first chamber, and the thrall was gone.
I searched for him, all arount the island, but nothing!

Had to go back to my base and teleport him home.
Lost all of his equipment.

Very bad.

1 Like

I lost one in the G3 Area of the map. I was out gathering wood with my bearer behind me. I hear him ‘hup’ like he was jumping, and turn around to find him gone.
I tried commanding him, running away from the area, and teleporting elsewhere to get him to teleport to me.
None of it worked and about a minute later I received notification that he died.

1 Like

It’s not just bodies of water. I can’t even run from the Den to New Asagarth without my thrall just stopping for no apparent reason and not moving. At all. Period.

I have to go back to the thrall, remove all gear and inventory, /home, and then rescue it.

I’ve received numerous complaints from players on my server, and have had to assist in retrieving thralls because of the same reason. Thrall AI is borked something fierce and it’s broken the ‘end game’ for us.

Of course no clue if this is the same but when my thrall stops following me a mixture of running out of port range and tell it to return followed by a move here command seems to do the trick for me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.