Thrall won’t fight

Game mode: Official PvE
Problem: Bug
Region: America

I have a problem where my thrall (captain) won’t fight fight the enemies . Im being hit and i hit the enemy too but my thrall just go to them and stand there doing nothing. I realize this after going in the dungeon of dagon and equipping him with the legendary weapon “lovetap” to test the bug with the watcher above/captain from below (all was alright before). Now he is pretty much useless and won’t fight anything anymore. The bug seems to persist even after going out of the dungeon

Steps on how to reproduce issue:

  1. Bring thrall in dungeon of dagon
  2. Equip him with lovetap
  3. Fight watcher above
  4. Thrall don’t fight

This is a known issue. A small fix to thralls not attacking. funcom please read

It is very frustrating. And the weird thing is it’s the only captain that is doing this right now. All of our other thralls (other captain included) do attack with no problem.

It’s likely she is bugged from the weapon switch. You can try a couple things.

Have her guard.

  1. Give her the lovetap and remove and replace a piece of armor.

  2. Place the lovetap in her main hand slot.

  3. Give her a different weapon.

After each test take her some where and see if she activates.


Thanks man it worked :slight_smile: i forced him to equip lovetap and he started attacking with it and i did the same thing with his weapon and it fixed the bug

1 Like

I am also having this same issue but with different human thralls, my tier 3s won’t fight. ^ will try above tips!

edit: actually, I took their weapon away after reading the other forum posted here about the known issue, then they fought with their fist and I put the weapon back and they started back using it! :slight_smile:

1 Like

Clearly it’s an ongoing issue that’s getting worse.

I’ve had the issue before, but I’ve had it three times today alone. T4 bearers just running up to targets and refusing to swing.

Tried everything I could think of and yet it persisted. So I swapped thralls and the replacement worked at first. Then 10 minutes later developed the same issue.

The only good thing is this forces less reliance on thralls for combat, because they have become completely undependable.

Teleporting into instant death locations, refusing to fight, sometime just disappearing and refusing to go home only to be found ‘living’ onto an obelisk somewhere for no reason.

Add me to the list of complaints in hope this gets a speedy resolution. Thanls.

Hey @HeXXeS333 welcome to the community. Are you doing any weapon swaps as started above?

I’ve been having the same issue since the last patch. Very rarely I can swap weapons and get them to activate again, but so far the only tried and true fix seems to be a server reset.

Things I do to get my thralls to join in when they bug out. I have many times had my thralls start walking backwards during fights like they are trying to slowly walk away… cowards. Anyway, I do the weapon swapping above, but its a time sink that can have deadly results in combat. (like trying to switch to a truncheon and finding its not on the wheel) Sooo, I will run away enough that the thrall will follow me out and it sometimes resets, or, put thrall between me and mob trying to kill me and when they get hit, they sometimes join back in. Also, sometimes when I hit them they “wake up” and start acting normal. This can also be spurned on by poison arrowing them. Pulling them away into follow mode is my most successful method to reset them and it can usually be done quickly.

Hello, bearers were extremely powerful and with 9.9k hp unstoppable. Imo they were silent nerfed due to they are intended to carry stuff not dominate. Hope this helps.

Not silently nerfed. It was part of the Warmarker patch notes. Here is the link to the notes if you’re interested in reading.


Hello, txs fer the info im still wet behind the ears ;).

1 Like

Yes I have been having this problem as well I have given my thrall a torch in inventory seems to sort confusion out lol of course sometimes he hits with the torch but they keep the aggro.

I agree, this should not be an issue still. I want so much to like this game, but stuff like this just makes me want to scream at the devs.

This and the fact that you can’t see stats on weapons and armor before you craft it. What kind of decision makers are running the show over there? If this was still in Alpha one might forgive this. But the game has been released since 2018