Thralls refuse to attack

For the last two days whenever I attack or get attacked by an animal or NPC…my fighter thrall and my bearer thrall (which ever is following me) will draw their weapon, run in, and just stand there!! They don’t actually attack anymore!! Help!! I am frustrated and ready to quit playing.

2 Likes

Try taking their weapon away and giving it back. Also if they have more than one weapon they sometimes get confused as to which end goes where. Last thing I know of is to tell them to stop following and the start them following again.

Have you reported this in the bugs forum?

Thralls are buggy right now. There are a bunch of known issues the devs are working on. Best thing you can do is report this as a bug and give as much information as possible.

This is a super annoying bug.

I know others have posted links to solutions, some being videos.

My best solution at this time is to take the thrall near where a hostile NPC can be found. Remove all of their weapons and place them into guard mode (sometimes just stop following - which places them into scouting mode). Then I let them fight bare-handed against the mob which I draw closer by punching it. Wait for your thrall to use their hands to fight the mob, then slowly give them the desired weapons back and re-test with each weapon they are intended to hold.

Additionally, the nature of their being bugged out, can sometimes be related to them wanting to use a recently equipped weapon type that they had. Two-handed vs one-handed. Bows are also complicated. You can sometimes get them to re-fight wish the weapon they previously used, but they might still not use other weapons in their inventory. An example of this, was I had an archer a moment ago who would use the mace or mace + shield, but would not use their bow, even when they equip it.

Testing these instructions, I took away both the mace and shield which they were using. The first attempt, they did not re-engage with the Hyrkanian Bow. This included setting them to just Scouting or Guard. In this case, I could not get them to re-engage with a bow.

I’ve tried getting them to take damage, from a hostile, but that doesn’t reset them.
I’ve tried switching which bow they had in hand, which didn’t have an effect.
I’ve tried switching the ammunition loaded into that bow, currently they only seem to use predefined but unlimited arrows (flint in this case).
Occasionally the arrow will pop into their inventory. I’ve tried removing and re-adding that arrow in their inventory.
I’ve tried moving out of their render area, hoping that they would reset eventually. No observable effect.
I’ve tried having another follower, follow me, with the bugged thrall still on guard. No benefit.
I’ve tried moving their bugged weapon between directly in their equipped hand and inventory, no effect.
I’ve tried logging off and back on (Online Private PvE) and even that didn’t reset their non-aggression with the problematic weapon.

Sadly the thrall was still not using their bow by the time I gave up on them.
Maybe they will be in a better state when we restart the server periodically.

This is why I have been adamant in reminding the developers through this forum that the issue is very important to the users, as it has been frequently occurring and is difficult to workaround.

I seem to write this on a regular basis so instead of typing it all out again. Go read this post it should help you solve the issue once it happens. This is not to say that these thing shouldn’t be fixed it is just work arounds for the issue you are facing so that you can enjoy the game until a fix comes.

2 Likes

I have the problem where I try to knock out a t4 thrall and my thrall will charge them then just sit and watch me, maybe he has empathy for said thrall due to what I put him through. Then when my thrall finally helps he refuses to use his 2handed weapon afterwards, sometimes a relig helps but not always. NEW CONTENT is good, fixed bugs would be awesome as well.

I’ve had this happen multiple times with fighter and archers. Sometimes archers will just shoot randomly and nothing even when there are no enemies.

Oh, sadly this bug has been in existence for a VERY long time. it stems from changing weapons the thrall had last successfully fought with (NOT the weapon he had when you broke him, but the last one he used after you thrall’d him before the bug). This seems to happen most frequently when we change from a real weapon to a truncheon, or back again.

Funcom’s bug/work tracking Trello STILL has this listed since Nov of 2018, and STILL just says,

“QA is unable to reproduce. Original report is from August. May be fixed already?”

Which is still mind-boggling to me, since I run in to this bug multiple times a day. QA needs to actually go play the f’ing game IMO.

1 Like

Wak’s link probably has some info on how to get them ‘unstuck’, which is an often tedious and sometimes harrowing experience.

Summary: equip them with the weapon you want them to use, and the weapon they last successfully used (for me it’s usually a trunch and a ‘real’ weapon). Get them agro’d on something that’s big enough to take damage for awhile, and watch them. They’ll switch weapons back and forth aimlessly, attacking with one and not the other. Eventually, if you’re patient and he’s tough enough, he’ll start attacking with the weapon you want him to use. Then quickly remove the other weapon from his inventory and off you go.

1 Like

Take the weapon from the thrall… Place thrall on guard … give him the weapon twice untill he holds it to his hand… Place thrall on follow… Enjoy

was tenderizer the only weapon he had in his possesion?>

The same issue is on xbox as well

This often works but unfortunately not everytime. Sometimes just have to wait for the daily server restart.

Well as @NosferatuV mentioned this ussually works… I have no idea on another way to make thralls aggro

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.