Video of thrall follower faulty behaviour

Game mode: [Online]
Problem: [Bug]
Region: [EU]

Follower is not attacking at all.
I got hit, took weapons away, added weapons, switched weapons, all the tricks I could think of.
This is a HUGE part of the game, and fails miserably.
Please. Look. Into. It.

Steps on how to reproduce issue:

  1. Fight something with a follower.
1 Like

So I tried to backtrack what I have used this thrall for before, and realized I was testing out different weapons with her.
After testing I switched back to her normal weapon and shield, but she did not initiate combat with that gear.
Gear she has used before successfully mind you.

I then recalled what weapon she had been in combat with the last time, gave her that, and BOOM she’s back in business.

Will now test if I can switch back during combat.

I put the shield and sword to her inventory and she switched to that right away after I started combat.

So to summarize:
Follower would do nothing with shield and sword.
Shield and sword worked before.
I gave her a greatsword for testing in combat.
I then put back sword and shield outside of combat.
She would not attack at all. Not even barehanded.

Gave her the greatsword which she had previously used IN combat and she attacked.
Then added sword and shield to inventory together with greatsword.
She switched to sword and shield and started combat.
I then removed greatsword from inventory and started combat.

Hey there @Kruttmusa, thank you for sharing your insight into this issue together with the video!

We’ve forwarded this information to the developers as its data will most likely be useful.

1 Like

This explains it better actually:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.