VoIP Issue / Fatal Error

Game mode: Online Private Servers (Multiple Reports)
Type of issue: Bug
Server type: RP/PVP
Region: United States


As of Saturday the 31st of August, VoIP has been stopping randomly for people, along with intermittent fatal errors that seem to coincide with it. This has been happening across multiple roleplaying servers that use VoIP.

Here are some of the solutions that have worked for people, keep in mind that even the solutions aren’t consistent:

  • Restarting steam, and logging back in sometimes works
  • Some people are flushing their DNS cache, and that randomly works
  • Closing Discord, and restarting Conan sometimes works.

These fixes are all inconsistent and do not always work, verifying the games files on steam doesn’t help with either the voip issue or the fatal error.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

Players login and will randomly be unable to use voip or hear others speaking. Players can tell that they have the bug because the mic icon doesn’t pop up when you use push-to-talk, and speak. They cannot be heard, and cannot hear anyone else.

8 Likes

Yeah many have been having this issue, taking hours of restarting to just getting it to work.

3 Likes

It would be nice if this issue could be resolved. For many voip is a key feature in roleplay as it is impossible to share intonation, spacing, timing, … over text chat.

Aside from that it is ofcourse an annoyance for many that are currently dealing with it.

2 Likes

When I first encountered it, I tried restarting steam, restarted the game a couple times, still had Fatal Errors when trying to join a server. Singleplayer had the voice bug (aka no mic icon popping up when talking). Steam microphone test (in steam’s voice settings) was shoving good results tho.

° Saturday, I verified the game files, restarted my computer, flushed my DNS resolve cache, started steam as an admin, started conan, direct connected - in that order - and finally was fully loading into the server again + voice chat was working again.

° Sunday night, after the server restart, I had the voice bug again. Flushing DNS and restarting steam as an admin did not help anymore to get the voice chat to work anymore. Though, there are some reports on discord that the /flushdns did help some people.

I am not eager to verify the game files each time i have a voice chat issue ingame. At least I haven’t had a Fatal Error anymore after the first temp. fix I had Saturday.
Some people say this could be due to an update that Windows did last… Thursday I believe? I run WIndows 10. But I know people with Windows 7 that also suffer from the Voice Chat issues, and W7 doesn’t get updates anymore.
This problems occurs on several servers with different mods. So I would not assume that this was a game server issue, either.

I hope the input helps tracking down the issue. Should anyone here get the Fatal Error again, please try and copy a link to an error log. Me derp haZ not done that yet.
Thank you in advance for looking of this. <3

EDIT: Error line says this

Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000000

!0x0000000000000000

3 Likes

I can admit I’ve had this happen to me in the past 48 hours I’ve had to do the following and nothing has fixed it.

-Boot steam up in administration mode
-Ensure that Conan and Steam are the only two functioning applications running
-Clear my DSN Cashe
-Reset my entire internet
-Restart my entire computer system
-Clear and reset my entire voice application system 4 times
-Revalidated files over and over again on conan alone
-direct connecting through the ISPN

During this time I’ve had:
8 consistant fatal errors
10+ hours without use of communication through VOIP

It’s extremely beyond frustrating when you’ve been trying for hours on end to just play a game and enjoy your time on it to see the results fail.

3 Likes

Saturday the 31st I did not have issues. September 1st I did have issue, logged into an voice activated server, no voice. I verified files, shut down and exited steam, rebooted, the computer, restarted steam in admin mode and had voice again on a different server from the first one. However on that same server, a population of about 32 people online at the time, more than 50% of the people I encountered has this issue where voice is not working, and in some of them not even the game audio could be heard. It’s very annoying and discouraging for players, causing disruption in playtime and folks do not want to play because of this issue. Related to the recent win10 update? Hurricane? Can we get some form of information about what’s causing this issue and how to fix it? Is it something funcom needs to fix? The Internet Service provider needs to fix? Help?

3 Likes

Tried everything. Some weird intermittent failure.
Can take anywhere from 5 mins to 2 hours to finally get VoIP and Conan to play nice together.
Please look into it really soon.
Our stories are dieing.
-Capt-

1 Like

Correct me if I’m wrong, but doesn’t VOIP go through another service server? Funcom didn’t patch anything, so wondering if that service is having some issues. Can’t recall the name of the company though to go check.

2 Likes

The third party program is Vivox, it’s a possibility that Vivox itself is having an issue. It started this weekend, so it could have to do with the Windows 10 update, maybe Vivox updated something with the way the voip is pulled from games? Hard to say, but there aren’t any tweets by Vivox mentioning outages that I’ve seen.

Hopefully, there are answers coming soon!

Hey @Bizcotto

Are these issues still happening at this moment?

2 Likes

Hey, @Ignasis

Yeah, it started for people this weekend, and has been that way since. I actually had it last night, which is surprising, I normally never have these issues, I’m usually just posting them for the sake of others! :sweat_smile:

That’s indeed weird. We haven’t changed anything on our end. We’re poking our team to see if there’s any known issues with Vivox at the moment.

2 Likes

Thanks, @Ignasis

It’s actually across multiple servers too, I can only confirm the servers that I’m whitelisted on, but players from those servers are having the same problems.

I was actually on a small private server last night testing building locations with a few people (5 altogether), and that’s when I started having the issue myself.

Do all those servers use the same or similar mods? Another thought I had was that to maybe check to see if any mods have been updated in the last few days that all those servers use. How a mod could affect VOIP? No bloody clue, but ya, figured I would mention the idea for investigation.

2 Likes

They’re a mixed bag of different mods, nothing modwise has been updated until today. I think a lot of the mods were waiting for today’s update. Boy, that would suck if a mod could scramble voip like that though.

Hey @Bizcotto

It seems there were some problems over the weekend that affected our datacenters, which affected the service that create tokens to coordinate with Vivox. It’s been resolved since then. Could you try restarting your server and see if the issue still persists?

1 Like

Hello, @Ignasis!

I’ll forward your message over to the admins on each server, and then post the results here when they get back to me! Thanks so much!

1 Like

Hey @Ignasis

Just got confirmation from the admins that the voip issue is still happening after a full restart. :pensive:

No fatal errors so far though, so that’s something? :grin:

This was happening before the weather hit the data centers in fact this has been happening since the latest windows update. There is a conflict between the Third party voip company and the software update windows did. Its not Isolated to just one locations it is across the board on many conan servers, along with single players. I am one of the head admins of a very popular RP conan server our community has been effected hard by this, In addition reaching out to other communities it is happening to them also. It’s not a Mod thing because each server runs different mods, and some don’t run any mods. Today after restarting the server I still has the voip issue. Fatal error itself didn’t happen for me but it is still happening to others.

1 Like

Hey all,

We’ve made some changes on our end. Could you try to restart your server and clients and check if this issue can be reproduced again?
Thanks in advance.

1 Like