Watcher Items not available for old characters

Official server 7059, Xbox, GT: DuchessDeary, IGN Yennifer. Watcher Items from event seem to only be available for new characters, old characters prior to update show the feat now available but I can’t learn them even with characters being 60. Icon is just brown. Please help

Still waiting for something official from them. A stratement, anything. Just official confirmation that they are going to fix it! Do I really need to start a new character, aquire all knowledge on Siptah, transfer to my other server and learn all the Exiled recipes again too? Are they aware of the time involved in this? I bet this will ultimately be their “fix”.

1 Like

Trying to keep this open & visible until we get some official word on what the hell they’re going to do to correct this.

I saw in a similar thread someone said to unlink your twitch account and wait 24 hrs and then relink it.

Yeah, I saw the unlinking steam account for 48 hours. Hope it works for all systems. Thank you. I have unlinked my twitch account & will reply with results.

Hope it works out for you :pray:

I tried 24 hours first. That didn’t work. Going to try 48 hrs now & will post result.

Yeah, I tried the linking and unlinking. Even made a new character on an official server and still didn’t work. You can see the items in feat but they look unlearned, even though I have points to learn feats, it doesn’t work. I have some of the items but when I try to place them, they are invisible. I can wear the watcher mask I had though. Only way to fully use items is on my single player with a new character.

Unlink twitch account not working tryed it but nope
But agreed same problem for me on x box

Okay, I waited a bit more than 48 hours & re-linked Twitch account to Conan Exiles. It still shows I have them, but will not allow access to them.

Still waiting for someone official to say… anything.

Basic Info:

Platform: Xbox Series X
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE
Map: Isle of Siptah
Server Name: 7050


Bug Description:

I’m not able to craft any items from the watchers set. They appear in my knowledge but have the brownish background like i havent learned them. Try clicking on them and nothing happens. My conan and twitch accounts are linked.


Bug Reproduction:

Log in, check knowledge…see it wont let me use them now.

Trying the relinking twitch method now. Will see if that works.

I have noticed that in my singleplayer I can craft all the twitch drops, royal armor, and Atlantean sword. But on my private server that I cannot craft or unlock them. I can see them in my knowledge. But I cannot unlock them.

Yeah mine still aren’t working…but i play on an official server

Playing on series x x box on a official pve conflict server
Have unlinket my twitch account and relinket it after 20 hours
The recepies showing up on my feats but they are brown like other recepies wher you need to invest points in but i dont can do that (have a lot of feat points left ) and on artisan tabel the recepies not show up

Same exact thing here. I would either like them to fix this, or fix character transfers, so I can reset my character & reaquire all the Siptah knowledge & transfer to Exiled Lands… again, which is not ideal, but I’m having staues & such destroyed in purges that cannot be replaced. Any thrall that fall through map with watcher gear takes that set with him & I can’t replace the set. Unlock the Wacther items for all, if you can’t find a solution, fcs. This crap with you breaking things that shouldn’t be broken with every update is getting old. What happened to all the nice looking armor that the Aesir station thralls wore before 3.0? Planning to sell us clothing for our station thralls any time soon? Fix the problems before selling us more false advertised gear like the Arcane weaponry that claims it does magic when it does not. Tired of crickets on this!

Am I seeing things, or did Watcher items just get removed from Feats altogether?

Edit: Never mind. They didn’t load into my last play session for some reason. Still can’t craft them outside of single player, but they’re still there

I’ll just add more to this everyday to keep it from locking & hopefully cast visibility on this. Tell us your plan for a fix, Funcom. I’ve been renting a server for years. I think we deserve some communication, at least.

I’m able to use watcher items in singleplayer (on PC).

Same issue here. I’ve unlocked all the Watcher Twitch Drop items and have crafted and placed them in the past but currently they show unlearned in the Feats and when clicking on them to learn them but nothing happens even with plenty of Feat points available. Admin mode spawning of said items shows unable to spawn as it does with the unlearned battlepass items/unowned DLCs etc.