Wheel of Pain placement bug

Game mode: [Online]
Problem: [Bug]
Region: [EU]

Hello.
Today I’ve noticed a placement bug that affects all versions of the wheel of pain. This one in particular causes the wheel not to be placable AT ALL, claiming it is either not aligned with the ground enough or not in contact with the ground, when placed on a specific layout of triangle foundations, wich forms a hexagon of 3 tiles edge lenght. Specificly take a look at this structure: (imgur)xa1BmW2.png
(Used SketchUp to pre-plan my builds)

If you try to place the wheel of pain dead center(or really anywhere) on that structure, the placement will not be possible. Only a few spots centered on the square foundations of the outer (blue) ring actually allow placement. Tho only is a stupidly tiny spot and totally off center.

Steps on how to reproduce issue:

  1. Build a foundation according to the plan shown above, out of TBlackIce reinforced Foundations and triangle Foundations.
  2. Try to place a wheel of pain on it(preferably Tier 2 or Tier 3) dead center or really anywhere.

Expected result:
Wheel should be placable just fine everywhere since it is a level surface to be placed on.

Actual result:
Wheel of pain is unable to be placed due to either “Not enough alignment with the ground” or “Not enough contact with the ground”, anywhere except a few tiny spots way off the center.

One would expect that the Wheel could be placed just fine but it wont.

Greetings,
SotS

6 Likes

Dead center is a problem because it overlaps foundations at the point where they connect. Same applies to shrines, refreshment statue etc.

Hi there, sorry you have issues with this. One question: is this on PC Live or TestLive?

The way I managed to accomplished this, is by using the mousewheel. Center the wheel of pain, ignoring the red cross and keep turning your mousewheel until it disappears. You may need to build scaffolding to get a good POV.

I had this same issue on ps4 pvp official server. I managed to finally place the wheel on it and then it would never let me put the last wedge for the ceiling in. I had to build a triangle tower on my building with crenulations to trap anyone inside that tried to use it as a door.

I had the same issue on PC. I found that you cannot make the wheel sit dead center, which makes it harder to craft walls and ceiling to cover it up. Only option I found was to place a slope at the top instead of 4 walls to close out the roof. This is having 2 walls high instead of 3.

This issue also appeared with the hack/exploit fix patch, which gived us lot of placement issues. Objects that was easily placed, are now a realy pain, and you have to turn and try to figure out a position where it can finally be placed, or not.

The wedge foundations are especially a pain. These triangles was still more complicated but have become very difficult to use in build. I love compose with wedge fondations because this allows much more originality in the building, but mostly i have to stuck to traditional square foundation due to these placement difficultities right now.

2 Likes

Tascha This is on PC LIVE. I will try and see if i can recreate the problem on TestLive. Tho I assume it wont be a problem for your QA team to recreate since I added the building plan to the Issue.

Ive Also noticed that this problem affects most if not ALL the larger structures, especially on the size 3 Hexagon center of my builds structural circles, wich is completely constructed from wedges.
And even smaller Structures have problems when you try to place them dead center on a hexagon.

It would be wonderful if we could have a bit more of a grace area where building pieces MAY overlap, since I also cant close the roof on my build above the greater WoP, because then id need pillars on the outer layer of the central hexagon, wich prevent me even placing the wheel.

And honestly the sloped wooden support beams are a joke as well since they provide virtually no structural support at all. It would be lovely for us to be able to restore them to their old glory via an .ini setting for PVE servers.

For whatever reason I cant mention Users or post pictures so this gets kinda tricky

1 Like

I have to add another important detail to this, the wheel CAN be placed but only if the foundations are almost level with or very close to the ground. as soon as you add another layer on top or try to place the wheel on a roof, you cant do it

Just as a quick update: it’s being investigated.

3 Likes

I have experienced the same trouble, I solved it by rotating the WoP around its center, it suddenly could be placed, so I guess this is some kind of alignment of edges problem…

Update:
Ive tried the way suggested by Dhurgan, but i couldnt get it to work on my foundation setup.

No rotation or lowering/raising it has helped with it being placable.

@Tascha It seems as tho the Wheel always misbehaves if you try to place it with no physical contact with the world mesh. AKA Roofs or raised foundations both create this problem.

Did this ever get resolved for you? Im having similar issues placing the statue of refreshment on my foundation floors. It’s placeable, but only if I don’t want it straight or centered. I had one previously and there wasn’t a problem.

1 Like

The game does not like you placing anything on a join between foundations (or ceilings). Try with a standing torch.

This is STILL an issue. I tried putting a Bower of JhebbalSag on a base of 4x5 foundations built up so there are no gaps under any foundation and I get the “Not enough contact” message any which way I try to place it. Honestly, I have dragged it with high mouse resolution over every possible location and the message is the same everywhere. Come on Funcom, seriously.

3 Likes

I know.
I play this game since very early-access and saw the building system going from “very smart and fun” to a “headache” system. This started with the first anti-exploit and cheat patches, and is still going worse and worser with each new patch handling exploits.

It’s realy punishing for builders, and people loving this world, and i’m happy that i play on my own server where i can use at least mods to help with that. As i was running testlive i went nuts with these “not enough contact with ground” and other errors while i tried to place pens, wells, and other bigger stuff.
Nobody like cheaters and exploiters, but we’re are all punished for them now !

3 Likes