Animation Bug prevents attacking/harvesting in single player

Game mode: Single-player
Type of issue: Bug | Performance
Server type: Single-player
Region: US/NA


This was reportedhere but I do not see it mentioned in test live patch notes or on Trello as such I’m re-reporting it.

Currently there is an issue where after a while you can not hit things that are low to the ground. This impacts multiple weapons, tools, harvesting, and combat. Currently the Ymir Hatchet, Mitra Ankh, Hatchet, Picaxe, Spear, and 1H swords are impacted in my experience. Harvesting Bodies, Rocks, Sticks etc can not be accomplished easily or at all as that Character animation is stuck preventing it from making contact. Attacking short enemies like Crocs, Spiders, Snakes, and Scorpions becomes difficult particularly with the spear as only the last attack in a combo seems to hit. This seems to be the case with one hand swords as well.

This issue can be solved by suicide, death, or using a chareditlite move (mirror) to reset the character model. Though these are only temporary fixes. Changing your spawn location also seems to help at times for some reason when you reload after doing so.

This is an issue that I have only experiences in my current single player game though others seems to have experienced it going back to EA.

This bug has a significant impact on QOL in a single player game. Single player bugs may also be the source of multiplayer bugs so it would be nice if they weren’t ignored.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Start a Single Player game.
  2. Issue will either occur or won’t see previous thread for more detailed info
3 Likes

Hey there,

We’re aware of this issue and have notified our QA a few times about it. However, it has been impossible for them to reproduce this problem internally yet. If anybody knows of a way to trigger this issue it would be of great help to our team.

Unfortunately it almost seems like it’s a completely random occurance, so I haven’t a clue how it could be reproduced consistently.

The only thing I can think of is that I noticed it started happening after I had established the groundwork for a decent sized base and began logging out there. I had started over with a fresh single player character and was watching out for this particular bug since I knew it existed at this point. It didn’t hit me on this new play through until then.

Don’t know that there’s actually a link there. Could just be coincidence. I just know that I was fine during the period I was just a wanderer and hadn’t set up camp anywhere yet.

2 Likes

I have since EA started 5 or 6 games single player, plus various shorter test games trying to reproduce bugs for people. This is the first time I’ve experienced it. At first it was intermittent then it become permanent then it went away. I have never “fixed” the issue with the mirror mod without first going out and farming so that I could gather data and only did if I was going to do something that would be impacted (never if I’m building with mats I have already or running to my first base were I have loads of fishing traps, or just trying to capture thralls)

I suspect that it is related to another bug that is on Trello so I didn’t re-report it (and I only did this one because it wasn’t even being shown on trello and the previous thread was closed) I almost always have a character that is tall. This is the first character that I had that was over 95% though.

  • We know that any character size above like 50% (default) will break clothing and hair physics. That has been an issue since EA too and has never been fixed. I honestly don’t know why the slider is even there if it is bugged. This game I decided I would make a taller female model not full sized but close I assumed the bug had been fixed being it is 9 months since launch.

  • The game started me near the broken highway (the far left spawn point) which was a first.

  • I came up from the south and started by building on the long island just south of the circular oasis lake with a giant croc boss. I then regularly travel north back and forth. To get the ore along the ridge near the summoning place (which I have done in nearly every game)

  • It started before I did the dregs and before I had a large enough supply of Iron to feel comfortable using Iron tools except to gather iron.

  • I use a Pike for my primary weapon. I use a 1h sword and Shield as my secondary option. The same game later experienced the Dregs bug. Where Sluggy was out of the pool and I had to finish her off with arrows (thankfully she was nearly dead as I only had about 50-60 arrows with me) Though this issue started before I did the Dregs but I am giving this just in case.

  • I built a large number of Fence Foundations.

  • My primary Deity of Ymir.

  • I had visited the Yog Priest before the bug was noticed.

  • I regularly dive under water. I know the “shelf” we are on with swimming has in the past caused animation errors in character models. The area where I’m diving also has the new high water walk animation so I sometime would rise out of the water with a jump and then end up in that new animation but it would jitter between that and the swim shelf for a moment.

  • I did go up to the Highway to get the Lore Stone, fought the imp king near it and followed the ghosts into the ghostly road as far as it was safe without falling off the broken bridge because I’m a dork. I also got the lore stone in the water near the sentinels.

  • My main structure is literally just outside of the range of sand storm.

  • I likely had 20+ hours of game play before it kicked in.

The Mirror mod fixes the issue. All I have to do is literally hit use > apply code. I change absolutely nothing and the problem goes away until I restart. All it is doing is just recreating the character model which means it is almost for sure related to the character model.

I don’t know if any of this helps. That is everything I did, as something caused it… of course it could also be a random bug. As the previous thread showed multiple instances… it suggests it is repeatable.

Things I did that I haven’t done in previous starts (that didn’t have the issue):

  • Built on a mesa for the second time along the southern river. Covered the foundation with fence foundations to the ground. In case I stayed long enough for a purge (I didn’t nor have I ever had one) to try to prevent base spawning. (however I have had significantly larger flat ground starting bases in previous games)

  • Character model was taller than I have used before. Female Model, Modest bust. Over 95% height. Physics for clothing and hair were broken. (Nearly every game my character model was over 50% and the physics being broken is normal… I used the chareditlie (Mirror mod) to reduce it down 50% trying to fix the issue, thinking they were linked.

  • Stayed along the southern river until level 35+ longer than any previous game. Switched between bedroll and bed both on a mesa very close to each other. Once I built the bed I picked up the bed roll.

  • fought the Shaleback king with an iron pike. Earlier than I had in other games. Later fought him again bringing a Butchers knife with me to get the head for the journey step. (Under level 30 I think)

  • fought Imp King near Lore stone at the Broken Highway (the broken bridge in the south with the horses… (teasing us with horses… bad funcom :stuck_out_tongue: ) ) I had never encountered him before so I don’t know if he is new.

3 Likes

I’ll toss in a bit more detail on my end just to add to what Kaziklu posted and maybe help track this down.

  • My character is short, near or at the lowest end of the scale.

  • Also started at one of the far left spawn points. Doubt that has anything to do with it, but it was mentioned.

  • Actually avoided building anything but a temporary campfire or two until I got to where I wanted a more permanent presence.

  • Bug appeared before I did the dregs as well.

  • Used the two handed spears almost exclusively so far. Only used a shield and bow/throwing spears for the Dregs

  • No fence foundations, but plenty of regular ones.

  • Deity is Derketo

  • Also visited Yog Priest before I saw the bug, but there is a significant gap in time frame between the two events.

  • I don’t dive that often. Too busy killing things on land. :wink:

  • Got the highway lore stone, did not run into the imp king and did not yet get the lore stone near the sentinels.

  • My base is on the border between the desert and the forested area, up the cliff above the Shattered Basin, on the mesa next to the first waterfall. Also just outside the sandstorm area and just shy of where it rains all the time. Currently consists of one fairly large building, a wall running around the mesa ledge, stairs to get up, one of each crafting station that I can build, one temple to Derketo, an animal pen and a wheel of pain. The bug first appeared while the building and wall was little more than foundation blocks for the base level and a furnace though.

  • 20+ hours sounds about right for me as well. I think I was level 25-30ish before I saw it happen.

  • I don’t use Mirror mod, or any mods for that matter. (Just after the vanilla experience for now. I’ll probably use some mods in the future. :wink: ) Pretty much all I’ve been doing is after I get logged in and wait a minute or two for everything to finish loading, I go into first person view and look down to check for the bug. If present, I remove the bracelet, which corrects the issue. Typically only have to do it once per session.

3 Likes

This is interesting. Which is why I gave as much detail as I could… I really wish we were told more often if a bug can’t be reproduced so this can happen.

There are two things I find interesting. We are both starting with extreme sized characters (opposite ends) Both outside the sandstorm and both in the starter area from the sounds of it… and both on mesas.

So my questions are just because more info is good and there is some over lap. How close does the sandstorm get? For me it is with in 20 foundation blocks (as distance scale) to where it would damage me.

Do you use a pick or hatchet while the sandstorm is active to the point you don’t get damage but you can see it pass?

Also just as an aside… how often do you walk away and leave the game running? I sometimes will tab out as I play in Windowed Borderless and watch youtube during the night and the game times to the point it does the circular camera.

So do you do anything similar… and just in case do you play windowed borderless?

I will mention I don’t use the Mirror Mod normally. I only installed it after the issue occured. I don’t play with any mods. I know the Mirrormod solves the Physics break so I thought this might be related.

As it happens the Mirror Mod does temporarily fix the issue so if it gets too bad… it does help.

1 Like

Sandstorm is a good distance away. I get a nice view of it when it goes by, but it passes just south of Bonepicker Camp, which is south of where I’m at. (I’m looking at https://conanexilesmap.com for reference, FYI.)

From what I gather, you’re still based at the southern river, yes? I’m way north. On the border between the desert and the northern forest area. In fact judging by the ruins nearby, I think the ghost fence used to run through where I’ve built. If you open the map, I’m almost right in the middle of it.

Not sure what you mean by using a pick or hatchet and not getting damage. If I happen to get caught in the sandstorm, I just put on my sandstorm mask and keep doing whatever it was I was doing, which sometimes does involve a pick or hatchet.

I generally don’t just leave the game running and generally avoid any alt-tabbing while I have any game running. A short trip to the bathroom or going to the kitchen to grab a soda or something is about as long as I just leave it alone. More than that and I just close it. I think the longest I ever left it running without doing anything was when I was chasing the cat, who couldn’t decide whether she wanted inside or outside. (If I ignore her she tries to claw her way through the wall. :roll_eyes: ) That took all of ten minutes probably.

Just double checked my settings. I’m set to windowed fullscreen.

Also, just as an additional note, the bug was not “active” when I logged in to check. (I went into the game and logged into my single player character because the settings get a little bit messed up if I enter the menu from the initial main menu, which is a separate issue.) However, at this time I’m out on a jungle excursion well away from my base with only a small bridge I recently built nearby. This is just one observation though, so it could again just be coincidence.

Addendum: Just logged back in after I was done browsing the forums here, so I’m still in the same spot I was a moment ago. Bug is active and the only thing I built that is in visual distance is a fiber bedroll.

1 Like

Ah sorry for some reason I thought you meant the swungle not the north. Ya my starter base was along the southern river. Now it is at the Hand of the Maker. Issue still occurs.

The pic and hatchet comment I meant do you farm while the sand storm is happening but while not being in the path but being very close to it. (Ie not needing a mask but you can see the edge of it.)

Hopefully all of this will maybe trigger something in a dev. lol Just trying to cover as much as possible.

I’ve often though I should just record all my play sessions and upload them unedited and say… there figure it out lol

1 Like

Out of curiosity because it happens in a single player game would it help the devs to actually have a set of single player game files where it occurs? Would it be helpful for a few people to actually send the saved game folder to them?

As a temporary work around, if you crouch after you hit the harvest key, you’ll dip down and be able to hit lower. It’s annoying but it works.

it does and I have gotten good at it… it doesn’t work for everything though. It does for mining. With the mirror mod though I just either go back to the chest I keep it in or just turn on admin and spawn one fixes the issues for the rest of the load in and works perfectly.

Also for me I’m 130 hours into the current play through as I stupidly keep base gather settings and I only just hit level 48. (I think I’m at the highest level I’ve been at) So temporary work around loses meaning at that point. lol. Honestly the mirror works perfectly every time so I just Bethesda a solution until the figure it out. Being as I have for the first time “reproduced/fallen victim” I’m happy to try to help and if packaging up the game file is a help I’m willing to do that.

Even though I have no idea if it is computer specific

1 Like

Yeah, I do that when I forget to check before I head out and don’t want to commit suicide while I’m in the middle of harvesting a bunch of stuff. Especially if it presents itself in the middle of an enemy camp. It’s a pain in the ■■■, but it gets the job done until I have the opportunity to go lay down and die somewhere.

2 Likes

The problem occurs to me almost every time I log into single player (and single player is all I play so I don’t know if this occurs in multiplayer), so these days I start playing by logging in, checking whether bug occurs (usually yes), removing bracelet, dying and then getting to actually play. I play on Civilized difficulty so at least I get to keep my stuff when I die, so this isn’t such a bother to me.

I do not recall the bug happening during play unless I actually log out. It only occurs (or not, although this is rare) when logging in. This used to happen with my previous character as well, but I lost its save files when I switched computers (dumb me simply assumed Steam would keep them - never assume!) so I can’t access any details regarding it and need to work from memory - although this bug was common enough that I remember it pretty well.

The bug occurred even before I installed any mods, and persists with the (cosmetic) mods I have. Since others have mentioned the height of their characters, my current character is a female of minimum height; however, my previous character was a female of average height and still suffered from this bug, so I’m not sure whether character height is a deciding factor, or even a contributing factor.

Unfortunately I don’t recall exactly how long it took before this bug first appeared for my character. I’m reasonably certain that I was able to make my first tools and build my first shelter (south of the noob river), even make my first stone pike, before it happened. I have a vague impression that I was able to play my previous character for quite some time before running into this problem.

Pure speculation, but I’d like to hear other people’s experiences: could it be related to unlocking a certain tier of tools/weapons? I don’t think I ran into this bug until I got some iron implements into my hands.

I’m also willing to send Funcom some of my save files if that’s helpful.

1 Like

Hey @Kapoteeni
If you don’t mind, it would be really interesting if you could send us your save file via direct message (you can send it to me, for instance). Maybe this way we can have a reliable repro case for our QA to work on :slight_smile:

Sure thing, I’ll send it to you as soon as I get home. Do you want the entire Saved folder (which is quite big) or just a specific .db file in it?

1 Like

Only the game.db file should be enough. If compressed, it can go down in size significantly too :slight_smile:

oh sure take the newbie’s file Ignasis :stuck_out_tongue: It’s ok I didn’t want to give mine anyway… I mean I have a super cool lunch here to eat and that is like totally enough. :slight_smile:

I do hope it helps them though.

Do you remember if when creating your character if you selected and extreme size? (ie either the shortest or tallest possible? Or close to it)

Yep, as I said earlier, my current character is a shorty - minimum height for a female - but my previous one was of mid-height (because I didn’t notice there was a height slider at the time…) and still suffered from the same bug.

And it’s clearly the beard that makes a new guy like me seem more credible in the eyes of the devs. There is power in beards. (But it would totally make sense if they collected game databases from more than one source, especially since mine is modded and probably not optimal for finding bugs in the game code - but maybe they can at least replicate the bug with it.)

1 Like

opps sorry totally missed that. I’m sick and my eyes are kinda glazed… I actually read your post 4 times looking for it so I didn’t ask if you did give it and some how skipped the whole paragraph you wrote it in every time lol

Also I have a stunning beard. It has actually been called magnificent by a total strange… hell a woman once knocked on my door to ask to scratch my beard… (I wish I made that up it was weird) :stuck_out_tongue:

1 Like