Animation Bug prevents attacking/harvesting in single player

So this is a really old bug. It affects all platforms.

The easy workaround is to take off your bracelet to kill yourself. When you respawn, the bug will be gone until the next time you log in.

It’s apparently partially caused the 1st time you tame and place a thrall…

I have not personally tested this since I already have a lot of thralls placed. I’ve just resigned to start each session with suicide and give up on using warpaints.

you know what it was likely around that time for me. However in previous games before the one I’m playing now, I’ve not had that issue. I’ve had loads of thralls and even had them in the same location likely literally placed in the same location. My Wheel pain is almost exactly in the same spot except it is on foundations this time.

It is 100% tied to the character model because the Removal of the bracelet resets the character model It is much more likely to be connected to a piece of gear or a particular weapon then placing a thrall unless it impacts all the character models in the game. Which may be the case we don’t notice thralls having these issues as we usually kill them fairly fast and their character models get reset I suspect fairly regularly.

Could it be this simple? I think it was around the time I put a couple foundations under a medium wheel I built on uneven ground when I started getting it.

I will say it got worse after the Halloween event. Before that I could fix it by reloading. Now only death fixes it. Maybe they changed something in that patch that’s contributing to it.

Also thralls do seem to be affected by the physics bug so they might be affected by this too…?

I literally just finished building my maproom so next time I load I will confirm it is happening (as it happens has been an active issue with all but one load in the last 2 weeks) after a teleport. I haven’t tried that.

I know that it is the character model which means a wheel of pain on a foundation shouldn’t be the issue. The Character Model can be reset with the mirror mod which is very similar to what happens to when you re load after death. A new Character model loads in the issue is resolved. Which means the issue is some how hardwired into the default character mesh that is load when the game loads.

For it to be connected to the wheel of pain or the first thrall placement it would have to be connected to the thrall model on the wheel of pain or the thrall mesh and it would cause a bug somehow that would have to impact every character Mesh including NPCs on load. Now I could confirm this by just grabbing a thrall with a spear and let them fight a Croc if they can’t hit it then it happens to all character models on their initial load.

My personal theory is that it is connected to the Iron Pike or Stygian Spear. That while using it the animation cause a error in the mesh that if you log out or die while that error occurs it gets stuck and that it is an animation that is impacted by or has it’s risk of occurrence increased by using max or min character meshes.

I’d be willing to bet it is connected to getting knocked over while changing animation or flipping tools while in the ending animation.

Like while doing so on uneven surfaces. Like the Ice Rink caves that still exist 9 months after launch.

I also suspect that it is tied somehow to the same bug that makes hair and clothing fixes break if you make your character larger than default.

I don’t know for sure. I can only say that is what I think has occurred.

If it is the wheel of pain or thrall placement then it would have to impact any thralls loading in at the same time as you and should be easy enough to test.

Ok so I just tested the idea that it is tied to thralls.

A thrall is not impacted by it. The Thrall was able to fight with a spear and high a croc. I flipped her over to just a Hatchet. She had no issues fighting with that.

However something interesting happened. I gave my thrall my hatchet. When I took it back after they are used it properly I could use it properly. Prior to the fight I could not hit sticks on the ground with it. My Pike heavy attacks went right over the crocs as did my sword heavy.

The Thrall only used the light attack and my pike continued to be nearly useless. My Thrall used the Hatchet and I could afterwards use the Hatchet fine. I will try that again just to confirm. If anyone can also confirm that as it is interesting. I’d love to know.

**Edit (Edit of the Edit I may have spoke too soon, the issue redeveloped the third time I loaded and just getting the animation to occur in a thrall out of combat didn’t work… will test it again in the morning)

Ok I need someone else to test this as the issue actually went away after playing with the thrall and didn’t reappear on my next two loads after making a thrall equip a hatchet. Spear and Hatchet Animations worked.

So Steps:

  • Load Single Player confirm the issue is occurring. Fight something try to harvest things. Do not take off your bracelet
  • Quit the game.
  • Load Single Player confirm the issue is occurring. Do not take off your bracelet
  • grab a thrall (any that will follow you) give them a Spear and a hatchet)
  • fight Crocs or Spiders on level ground.
  • take the spear away from the thrall to force them to use the Hatchet
  • try to harvest something you wouldn’t be able to.
  • Quit game
  • Load single player. Confirm Issue is no longer occuring. If it is…
  • place a Hatchet in a Thralls hand to make them equip it and do the equip animation they do.
  • Test if issue is still occuring. if fixed
  • quit and reload to confirm it is still fixed. If not fixed let me know so I can scratch this off my brain.
1 Like

While I’m pretty sure placing a thrall may have some impact - Scaling player size and thrallbreaking don’t really factor into this as I have it happen to me regularly on games where I’m at default size and have no thralls.

I’m not sure but best I can guess is that there’s something causing whatever system they have set up for aim-offset to break when your character model gets loaded into the game. From everything I’ve seen it seems to be a completely random occurance and it’s also just as random that dying or killing yourself will fix it; though it not clearing up after something like that happens far less frequently than it breaking in the first place.

while that very well be, theorize possibilities and eliminating them helps narrow down the cause.

It could be a specific use case with a specific weapon that requires a specific set of events to happen in a specific order. However if for example the Thrall using a hatch some how fixes it that may actually point to the animation mess up occurring with a hatchet. So getting as much data as possible even negative data in this case is a positive.

I’m more trying to find out what it isn’t with the slim to none chance of finding out what it is.

To be honest everyone that had this happen in EA should have likely tried to do this then. (Though there are fewer large bugs now so it may be easier)

It’s really quite simple to see whether or not your character model is broken. What causes it, I don’t know, but it happens when you load into the game. I’m guessing a lot of people don’t notice at first unless they immediately try to start gathering resources or killing something because it’s something you won’t notice at first.

When you load a game just look down at your body in first person view, if you can see down your neck and into the inside of the character model, then the aim offset is broken and you may as well just remove your bracelet right then and there. Ever since this issue first started showing up in EA doing this has become essentially a reflex for me.

I don’t think I’ve ever used the Stygian Spear, but the Iron Pike is something I try to get as soon as possible. The time when I first experience this bug would fit somewhere around the time when I unlock the Iron Pike, so you theory may have some validity, and sounds like a more likely cause for breaking the character model than thrall placement. It’s probably worth checking out.

1 Like

Hey people,

Quick update: Thanks to the savefiles you’ve been sending to us we’ve been able to replicate this issue internally and see the problem in action by ourselves. Our team will look into it now that they have something to work on. Thanks again, immensely, for your help and patience :slight_smile:


Good to hear :slight_smile:

1 Like

This is the physics bug I was talking about that seems to affect thralls as well. It’s also definitely connected to the wheels.
It’s caused by adjusting your character’s height during creation, but it doesn’t kick in until you place a wheel and change your clothes. And if you destroy that wheel and reload, the bug goes away until you place another wheel.

This could be related, but this bug affects characters of all heights so I’m not sure.

Glad to see you guys were able to help them track it with your saves.

Is your character still fixed from that hatchet testing?

1 Like

I don’t recall saying player size was affecting this…?
Simply pointing out thall placement was discovered to be a part of it. I mentioned breaking them because the 1st time you would encounter it is when you place your 1st thrall, which you would need to break 1st.

The fact it happens to you without thralls is interesting actually. Are you playing multiplayer or solo in those instances?

1 Like

It was in regards to something someone else said further up, but that’s the previously mentioned physics bug that effects hair and clothing - I still haven’t figured out how to reply to more than one person on this thing and you were the last person in the chain, my man.

And it’s solo, as far as the thrall placement. At the risk of sounding like a broken record - it strikes whenever your character model gets loaded.

NOW: this is where things get sticky because I always play singleplayer so if it happens, it happens immediately - I don’t how this is effected if you play online and your character is technically already spawned but just unconscious in your base; yeah, you gotta load into it in your client but for the game you’re already there and it doesn’t need to spawn a new ‘you’. I’m actually hoping to hear what the cause of this was when they fix it.

1 Like

haven’t been able to load in… my test last night suggested no… but I want to test a little to see.

Though I offered they never asked for my save (with the mod in place it is better to have gotten full clean saves anyway and I don’t have a clean one with it, though it was installed after and solely to deal with the issue and does nothing but change the character model)

It is interesting I didn’t know that was caused by the Wheel. I’ve never put that together. I also always just reserved myself to the bugs and there were also usually much worse bugs in the game. (Though I find it interesting that they have never removed the slider… or fixed the bug. )

If it were tied to the wheel though that would have to mean it was also an issue in multiplayer as I’ve had the physic bug online. Yet it doesn’t happen there as far as I know… which suggests that it would be something “server” side that occurs in single player but doesn’t happen in multiplayer.

That though would only be the case if they are indeed tied. At this point I will let them work and if they need info I think the community can help as they are working with us.

I can say I don’t know why it worked last night but did not work today. I tried the exact same thing didn’t work.

Basically it’s time to wait and let the devs do their thing.

just a reminder this is still occuring and there is no trello note. That means others are making threads. So I’m just going to bump this as a gentle reminder. As well as to link to the other thread in case that threads OP doesn’t add here.

Game mode: Singleplayer, Multiplayer
Type of issue: Bug
Server type: Any
Region: Any

Can’t hit or aim vertically, weapon or tools wont follow the cross hair.
This bug seems to have been reported before but i didn’t see any fix for it.

  1. Not sure how this happened, i have tried to restore settings, suicide, re-create character, start new game etc. nothing works. This is happening in both single-player and on multiplayer. Seems this bug is only happening to me.

Is your mouse cursor itself off too? Have you checked that your resolution matches your monitor?

My resolution and mouse cursor works correctly. Aiming Horizontally works as intended. When aiming vertically the animation wont change. Its like the character animation is locked.