Come on Funcom This is Not Fun

Game mode: [Offline | Singleplayer]
Problem: [Crash | Bug | Performance | Misc]
Region: [North America]


So I am guessing Funcom has given up on PS4? There is literally no way to play now. It is crashing ever 3-5 minutes. I am playing on a single player offline world. I have to restart the game constantly. You can not do anything in this game without it crashing. I am guessing it is a memory problem. There is no way in hell this game should be released on PS4. It is really bad when Ark is a better experience then what you are giving us here. I really wanted this game to be awesome but as of now it was just a theft of my 60 dollars. Oh and 10 dollars of DLC. Thanks for nothing Funcom.


Steps on how to reproduce issue:

  1. First get a PS4 because apparently you don’t have 1
  2. Second waste your money on the game.
  3. Third play the damn game.
  4. Fourth, Be mad at Funcom for stealing your money
5 Likes

Welp, just tried restarting again after a crash. Guess what. No single player save found. I guess it either corrupted or something. This is officially ridiculous.

1 Like

Try it again a little later, it did that to me too, I closed the game and started it anew, and it found my save. Of course I had lost items and chests, but oh well…

Apparently they have no idea what’s going on, they’re ‘investigating.’

EDIT:

Logged off by exiting to menu, I got a frozen loading screen. I was in my base when I logged off. Had to close the game manually. Logged back in, I was in the desert. Went back to base, I only lost the map room I had placed down half hour before this happened upon the frozen screen. At least I am in single player and I can respawn it, but this is beyond ridiculous, no offense now, Funcom…

1 Like

Yeah so. I basically had to start all over. Thought maybe if I delete all saves I have this will work. Did that. Started over. Now when I die I can not spawn back at my new bed roll I put down. Keeps starting me from an earlier period and in the desert. All feats have started over. Still have perk points but that is it. Just uninstalled the game and redownloading it now. I will try this and that is it. I am tired of it. It has basically become an operation to see if I can play the game at all and this is only on single player.

1 Like

The team is actively trying to reproduce this issue in house but so far we have issues doing so.
It would be really helpful to get the actual steps if you are able to reproduce it from your side.

2 Likes

Ok. I am not trying to be rude here and I will post it to the best of my ability but I have to ask something. Are you or any of the devs actually reading the forums rather than just glancing at them. Because this is a problem that everyone of your console players are having. Been having and seems to only be getting worse. I have read so many topics looking for answers that I literally had to stop because there is not enough time in the day. But oh well here goes…

-Start the game… on PS4.
-Play single player, offline, or for that matter anything.
-Build a base. I find it happens more often in or around your base. Especially when you have thralls in crafting stations.
-Sound will lag. Been a problem. Eventually if not right away the game will freeze. Either when moving items out of boxes or vaults or crafting stations. Now the game literally will do 1 of 2 things. Either you will immediately be hit with an error code from Playstation which crashes the game. Or you will have to go back to dashboard and close out the application and restart it. I own three copies also. It happens on all 3 and one is a PS4 pro and the others are regular PS4. My kids wanted it also. It happens on all 3.
-Now that this has happened it will start to happen rather regularly. I am pretty sure it is a memory issue the game is having. Eventually it will either start deleting items upon restart or will not be able to find your save completely which means you have to restart from scratch.
-And also it is making the PS4 fans run nonstop. Like it is to much for the machines. Read other comments on here about the game doing this and it does it to all 3 machines I have. I am not sure the game is really compatible with the PS4 at the current state and if so then it is HORRIBLY optimized.

Again this has happened to everyone I know that owns the game and also all over your own forums and also on reddit people talk about it nonstop. Not sure why this is not being taken more seriously. Like this should be what your whole console team is focusing on. This and only this. Nothing else. No one will ever buy another DLC, another game, anything, until they can actually play your game.

Thanks for the reply again.

2 Likes

This issue happens in single player, offline mode on PS4. For instance in my case, it started a little more than a week ago since I built a base with Khitan building pieces, I don’t know if that made any difference, or it was because of the latest patch.

I’ve played single player, offline since the game launched for PS4, and this didn’t happen until last week. First time it happened, I was in the volcano, I had put down a wheel of pain near the Well of Skelos. Since I play in my own session, there is no decay, no purge, no losing items on death. So I removed bracelet to spawn next to my bed. As I spawned in my base, I waited a bit to have it load around me, then I took maybe three steps from the bed to the door, and game froze. I stood there for maybe almost two minutes, game unresponsive, so I dropped to PS4 desktop and closed the game from there.

I restarted it, and upon entering the game, I was at the Broken Highway, in the desert (my base is near Trapper’s Cabin, in the highlands). All my journey steps were reset, I had the beginner ones, like climb, kick, find sings of intelligent life. My feats were in order, and so were my attributes, just the journey steps. I opened inventory, and from it all the demon blood that I had gotten in the volcano at the rocknoses was gone. Actually the wheel of pain was before the rocknoses so they were the last monsters I killed in there before I removed bracelet to go back to base. And in light of what happened today, I had also just attuned bracelet in the volcano. So back to logging into the desert; I travelled back to base by removing bracelet. In the base, almost all the items placed on tables were gone, like plates, tankards, candles and so on.

Went down into the base’s basement, where the stations and the crafters are, all stations were there, no thralls gone from the stations either, but there were two chests missing, and some wall signs next to them. Now, I can understand that the demon missing was the last thing I did before game froze and had to restart, but the items on tables and the missing chests were crafted a week before this happened. So the game not only erased what I did a few minutes before it stopped working, it also deleted stuff that dated a week back. I am underlining this because it might not only be an issue of not saving correctly on exit, that base with the stuff in it had already been saved like a week before this happened.

And now to today, I went to volcano again, by using a map room I just crafted today; to my dismay, the volcano obelisk wasn’t attuned. I actually had it attuned last week, right before I killed rocknoses and got the demon blood, then game froze. So that also didn’t save correctly when the game crashed. So I went on foot into the volcano again, re-attuned, got the serpentine weapons, then removed bracelet, went back to base. All good. I kept playing maybe 10 minutes after I got back to base, then I chose Exit to menu, so the game would save as I logged off. There is the loading screen, to take you back to main menu. Loading bar looked like it had a sliver left to complete, and then it stopped there. I let it sit for more than 2-3 minutes, didn’t move. Dropped to desktop, had to close the game manually again since it was unresponsive.

Logged back in, I was in the desert again; feats were fine, attributes fine, inventory looked ok. I used bracelet again to go to base, map room was gone this time. So this is how it happened to me, as detailed as possible. Let me know if you have more questions.

Thanks!

EDIT:
The first time my game crashed, just like @AnthonyWC70788 mentioned, game couldn’t find any save file. So I closed game again and next time I started it, it loaded my save, albeit with missing items.

And this all happens on a base PS4.

2 Likes

Yes, we are indeed looking at the forums. That is the reason this issue has already been listed in the known issues sticky at the top.

Thanks a lot for the additional info. :slight_smile:

@ArhurEld thanks for the additional feedback!

4 Likes

That has been listed there for a while now. Any idea when will it be fixed? Reading post on here it would seem like the team still has not been able to reproduce it. Which means there is no fix coming anytime soon. Also I hope they realize this is affecting every person that at least owns a PS4 version. Not to mention XBox. Sure seems to be alot of money they are about to be missing out on. And thanks again for your reply. Wish things got fixed as fast as you reply lol.

2 Likes

The issue has been added last week. It has not been there for long (single player and general save issue which leads to disappearing of placeables). As mentioned, we are currently trying to reproduce it internally as it is investigated.

Believe me that if there was a “fix now” button, we would all love to press that one. Unfortunately it’s not that easy, even if it might seem that a bug is pretty straight forward. (which it never really is ;))

5 Likes

Ah ok. I just think they are looking at it wrong. It is a crash or freeze issue that just so happens to result in disappearing of placeables sometimes. Which means it is a performance issue which is what needs to be fixed. And also something they say is something that always needs improving but what really should say everything else is on hold until this is corrected. Just saying.

3 Likes

Yes, that’s correct it’s a recent issue, that really started cropping up after the hotfix, with the DLC changes, was made.
Fixing an exploit that stops 50 points in each attribute, suddenly players start experiening attribute points resetting and progress loss?
Fixing collisions/connections on foundations, suddenly parts of bases start disappearing?
Coincidence? Maybe
Could those things be linked?
Probably.

If game idles too long(I.e with no player input) in singleplayer, it will stop saving, kinda like when you idle to long in an MMO and it disconnects you for inactivity.

For example, leave ironstone in furnace, go for Cigarette break, game will still, mostly, save progress.

Leave ironstone in furnace, go for dinner, shower, several ■■■■, comeback, play for another few hours, progress lost from stopping idling point through to next game restart.

When character points reset(this appears to happen randomly upon loading a saved game) although will 5 out of 6 times reset character attributes on crash, but not Feats.
All attributes are lost, but character remains SAME LEVEL, Level 42 with no attribute points(well sometimes 5 in encumbrance, but that’s not a consistent outcome).
This can be remedied by using a lotus potion.

Although, that doesn’t really help when your Foundations holding you manufacturing benches disappear leaving you with no way to make the potions…

If anyone at Funcom loads a PS4 or PS4 Pro, plays yhe game for a few hours, literally all these problems will be witnessed.

It’s the simple.

Fixing not so simple, which I understand, but this product, CLEARLY, should not have left early access yet, as the most basic QA would have shown.

I really feel for the community managers, because they get harassment for a product they usually haven’t made, while simultaneously getting very little support from the Devs or the community, but this game, in its current state, is a total shambles.
Moments of genius, nearly obscured by the overwhelming number of gamebreaking bugs.
I cant get past level 51 because of character resets and equipment/building losses, that’s gamebreaking, releasing a product that can’t be completed.
Hours of progress, NOT SAVED, correct me if I’m wrong but one of the features, in game, myself and others paid for, was the ability to save progress, particularly survival and constriction progress? Sounds gamebreaking to me and many, many others.

This game should not have been released as is.
Funcom not acknowledging this fact, is insulting to the community.
(Gamer of 25+years)

4 Likes

Note, the blanked out word was me using a term for Cigarette, that we Scots use, not intended to be offensive, I corrected one before I posted it, but unsure how to get back in and edit the other, sorry.

2 Likes

haha you got the DLC haha. shame on you for supporting this garbage

I did not make the connection with inactivity. Since there is not a pause I will often find a safe spot and then afk while I take care of irl stuff then come back and play. I do this a lot as having 3 kids take me away from the game often. I wonder if the patch for afk kick is what messed up single player. Timing would make sense

2 Likes

Would first like to thank you for not sending a “cookie cutter” response to this issue. If I am reading this correctly Funcom is no closer to a fix than when the issue started. If you can not replicate the issue I guessing your not going to be able to fix the problem. Would it help solve the problem to have a PS4 that the issues exits to go through? If it would help (with Funcom paying for shipping both ways) I would be willing to give mine up for a week or two so your team can replicate the problem. Maybe that wouldn’t even work, I’m definitely no tech guy as it took me 15 minutes to figure out how to even reply to this. We can all complain and whine about this issue and believe me I have swore Funcom’s name many many times, but with no fix for this in the near future I’m not sure what else can be done. Just an option.

3 Likes

Hi Derek, can you try something for every body here? try to erase you game save settings, (just the settings) . then restart your game, then re-pick your difficulty, even if it was custom settings, and see if you still have the same problems :slight_smile: and please post here your results, thanks

1 Like

Wish I’d thought about or known the lotus potion trick. Or even just thought to make admin and reset. But I had wanted to test something out so I just threw that away.

I deleted the game, downloaded the 56gb mess, new clean game. Starting new is always great but its because I don’t build big at first or chase many Thralls.

Standard PS4, singleplayer, offline.

This time I skip all that, admin to 60, set feats and attribures. Run to the black galleon where I usually put my first big-ish base, mainly due to an overhang for a single drop elevator down to the river.

Instead of my usual starter I build up over time, I go for a “compact” 2 temple design but still with overhang on back. Instead of open floor, more like a home interior design. Instead of simple pillars with a couple foundations at bottom for overhang, lots of foundations, fence foundations, walls, crenellations. Main base interior is 15x8 plus one outer foundation shell making it 17x10, plus guard posts to break up exterior lines, make it look more like a castle. Another good 15+ tile run out back with two 3x3s for compost and planters and beehive for the aesthetics.

At this point, bit more lag, not bad. Add lights. Add more lights. Get light crazy. Still ok, bit more stutter, but ok.

Add stations, add crafters, add archers, fighters and dancers. Equip them. Add in all those items from last game and the chests. Move things around. Move more items around. At this point I start getting the freezes. They start happening steady when I populate the game with all the game items you need to progress. All the inventory madness to feed the supply chain and asset management.

Note I’m not harvesting. I’m not using the crafters to make things. Just spawning what I need to build. Not one is doing anything other than standard crafter animations, side saddle waddle bounce and dancers dancing. I did fully upgrade all peaceable Thralls with weapons and armor.

Freezes (not hard crashes) seem to happen around saves. Use to, always only lost 1-3 actions from right before the freeze. Post DLC now it can be more. More time, missing items, screwed attributes, duped items.

Hard crash, one. Luckily nothing much lost, no craziness this time.

Build a fully closed off greater wheel just outside Set city. No Thralls, archers, fighters or dancers. Just wheel, small campfire, 5 chests. 9x9 total with outer shell, 4 high, guard posts to break up lines and crens. Still getting unrecoverable freezes but hard crash, not yet.

Place tower 3 tile wide side, plus outer shell and small overhang into water in Set city. Fish traps, elevator, guard posts, fence foundations. Every bit I build makes game worse without adding additional Thralls or items. Like crossing a tipping point.

Started adding placeables in tower. Lights, then downstairs large campfire, chests, 3 furnaces, stove, 2 preservation boxes, 6 presses and ginger, 2 cauldrons. No thralls, no items, only personal inventory access during building

A hard crash. Everything after lights was wiped. Stats still good, but that by of fiddly work was lost.

With years working operations in large multinationals, it sounds like memory leaks, memory space constraints probably exacerbated by DLC items even without purchase, poor optimizations in memory mangement and probable race conditions and/or deadlocks depending on how state is being saved.

With a closed platform like a console I cannot dig in and look at metrics under load or parse logs for clues. Throw in additional new processes and cleanup scripts (AFK kicker, anti-griefing land claim, server post restart state management scripts for placeables, item scrub for dupers). Make it worse if you are overloading exisiting functions to save time on fixes means unintended bugs in non-related processes. All things I’ve seen in other industries with bigger teams, more money and more time but seem to be a common thread to development mindsets.

6 Likes

I did that, the week before the last. It worked well for a few days, then these problems cropped up.

2 Likes

Maybe a corrupt save file then, i dont have any of these problems, but i start a new game every New patch, or update. did you try starting a NEW game? if you decide to, make sure to erase both the save game file and the settings file :slight_smile:

1 Like