Dynamic Building Damage Isn't working! (Gonna Report this as Bug/not working)

**Game mode: Online Private
Type of issue: Bug/Misc
Server type:PVE-C
Region: US


Since the I’ve tried countless conbination of settings here i’m gonna post this as a bug.

These are my Current Settings. From Testing this on my server with another player. Offline players bases can’t be damaged but online players can be. What Combination do i have to adjust to get it to work?

I’ve tested it on Player who has been offline for two days, and been testing it on a Player who is currently online and neither of the two bases are taking damage when i attack them!. Only my own base when i hit it. I really would like an official response or proper clarification how to get this set up correctly! i was looking forward to this Dynamic Building Damage, But it’s not working!

Update: Trying to figure this out some more…

So Changing the Settings to this(See Below) Is making so even the offline player Structure is being damaged as well as the online Player Structure!

With just this enabled can’t damage the online or offline player’s base

Add the other option, and still can’t damage either players base.

  • Conclusion Dynamic Base Damage setting is not working right now, Having it enabled along with the option to “Can Damage Player Owned Structures” Prevents the online player’s base and the offline players base from taking any sort of damage, even if the online players thralls are actively trying to kill you.

  • Adding Time Restriction on in addition to having “Can Damage Player owned Structures + Dynamic Building Damage Enabled” (But Not filling in any of the times in) Still does not allow for Any Sort of Base Damage on either the online of offline Players Bases. (Thralls are Still Aggro)

  • Only Combination that’s working is the Offline/Online Player Bases Taking Damage. Ir the Offline/Online Player Bases Don’t Take Damage!

  • Selecting “PvP Allowed” On Time Restricted PvP Base Damage section Is making the offline guys base Take damage! even if Dynamic base damage is enabled.(Which Should prevent his base from taking damage since he is currently offline, but it’s not!)

  • An official Response to this would be welcome, as i think the setting is currently borked. It should be a simple of case of Ticking the “Dynamic Building Damage” and also just simply checking “Can Damage Player owned Structures” So make it so online player structures can be damaged and offline players can’t. But it’s not working! It really isn’t working! I know it’s early access, But this is something that should be fixed if my findings show it isn’t working for some reason.

Tried following this. In Attempt to understand Dynamic Building Damage

Tried following this and this

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

More stuff i’ve tried toying with see below

So yes! as a Private Server Owner I literally can’t get dynamic building damage to work! What Settings in the Ini Dictate this. Since i really dont think it’s working. This is taken from my Server.ini file Everything that is related to base damage is enabled correctly. To note too, Pvp/Stealing is enabled 24/7 on my Server. And i’m trying to work it in that Player Buildings can only be damaged when the player/clan is online. Again, i can’t get this to work. Even as i mentioned with the Box checked for Dynamic building damage and the box checked for can damage player owned structures, it’s not working! I can’t be the only person with this issue!

PVPTimeMondayStart=0
PVPTimeTuesdayStart=0
PVPTimeWednesdayStart=0
PVPTimeThursdayStart=0
PVPTimeFridayStart=0
PVPTimeSaturdayStart=0
PVPTimeSundayStart=0
PVPTimeMondayEnd=0
PVPTimeTuesdayEnd=0
PVPTimeWednesdayEnd=0
PVPTimeThursdayEnd=0
PVPTimeFridayEnd=0
PVPTimeSaturdayEnd=0
PVPTimeSundayEnd=0
PVPEnabledMonday=True
PVPEnabledTuesday=True
PVPEnabledWednesday=True
PVPEnabledThursday=True
PVPEnabledFriday=True
PVPEnabledSaturday=True
PVPEnabledSunday=True
CanDamagePlayerOwnedStructures=True
DynamicBuildingDamage=True <
DynamicBuildingDamagePeriod=1200
PVPBuildingDamageTimeMondayStart=0
PVPBuildingDamageTimeTuesdayStart=0
PVPBuildingDamageTimeWednesdayStart=0
PVPBuildingDamageTimeThursdayStart=0
PVPBuildingDamageTimeFridayStart=0
PVPBuildingDamageTimeSaturdayStart=0
PVPBuildingDamageTimeMondayEnd=0
PVPBuildingDamageTimeTuesdayEnd=0
PVPBuildingDamageTimeWednesdayEnd=0
PVPBuildingDamageTimeThursdayEnd=0
PVPBuildingDamageTimeFridayEnd=0
PVPBuildingDamageTimeSaturdayEnd=0
PVPBuildingDamageTimeSundayEnd=0
PVPBuildingDamageEnabledMonday=False
PVPBuildingDamageEnabledTuesday=False
PVPBuildingDamageEnabledWednesday=False
PVPBuildingDamageEnabledThursday=False
PVPBuildingDamageEnabledFriday=False
PVPBuildingDamageEnabledSaturday=False
PVPBuildingDamageEnabledSunday=False

It’s depressing that nobody else is mentioning this problem… I can’t be the only one. I was so looking forward to this Dynamic Building Damage, but it’s a mess and i can’t get it to work. Either because of something on my end i’m forgetting to do, or that the setting is completely borked and isn’t working and Funcom Don’t care.

More Updates. I turned me server off for a moment updated these lines to All True, rebooted the Server And still can’t damage either the online or offline players base, Can only Damage my own… Like come on! How the hell do i fix this… It can’t be hard just to toggle Online Player Damage enabled and disable damage for offline players… You’d Think the Dynamic Building Damage Option would do something but it’s not!

PVPBuildingDamageEnabledMonday=True
PVPBuildingDamageEnabledTuesday=True
PVPBuildingDamageEnabledWednesday=True
PVPBuildingDamageEnabledThursday=True
PVPBuildingDamageEnabledFriday=True
PVPBuildingDamageEnabledSaturday=True
PVPBuildingDamageEnabledSunday=True

Another Update: Trying to play around with Base Damage Hours to see if that works, but so far even if i have it enabled during a set timeframe (6pm to 11pm for example) Base Damage is still enabled for offline and online players or disabled for both online/offline players. I swear to God, this is starting to annoy me, Dynamic Base Damage IS NOT WORKING!

All i want… Is for Online Players/Clans Bases to be damaged. And Offline Players/Clans Bases not to take Damage. Why is this so hard to get working?

  1. See in the Screenshots
  2. The Feature isn’t working.
2 Likes

I have the opposite. The moment I have Dynamic Building Damage selected. No matter if players are offline for a couple of days and even if it is out of raid time, offline players’ buildings take damage.

Damage for offline players only stops once Dynamic Building Damage is de-selected.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.