Funcom Launcher is live (2021-03-24)

Um, shouldn’t this be handled by the installer? Wasn’t the whole point of having Steam (et al) to have things Just Work™?

1 Like

I’ll just have to agree to disagree here. The vast majority of “launcher’s not working” complaints here seem to be about it not rendering properly due to display scaling, and that’s 100% on Funcom.

1 Like

Yeah, that’s all too common on these forums in general. :confused:

1 Like

do i have to buy isle of siptah so i can play the base game now. i wish to know because i do not have a continue button.

You don’t need the Isle of Siptah DLC to play the base game. If you don’t see the launch and continue buttons in your launcher, it’s most likely because your display scaling is set to more than 100%, as explained by @The_Ravenkiller:

1 Like

Its the wrong version actually 0.24.10
since march 16.2021
no chance to update

The laucher is not responsible for the steam updates though. It just arranges the mods for you. If the mod doesn’t update, your issue is with steam workshop. Verify the integrity of the files and restart steam. This sometimes helps if the mod update is not detected @TheRedMother.

EDIT: I don’t use EEWA but I did a test with it. If I subscribe to the mod, the pak that gets downloaded from steam shows 0.24.9 and when I download it from the link provided by the author it still shows 0.24.9. It might be something worth checking with the mod author as the mod is updated but I am not entirely sure whether the mod author needs to update the version somewhere for it to be read correctly by the launcher.

Launcher for Conan Exiles is not working:
Launcher itself opens, but the window seems to be cut off at the bottom, so the buttons “Launch” and “Continue” do not show.

Is there a way to open the launcher separately and then choose conan to play rather than going through steam? I also play The Secret World and Anarchy Online and would be great is i could just use the launcher like Battlenet or Epic so i don’t have to go through steam each time :slight_smile:

Is your display scaling set to more than 100%?

Thanks for the info if not the attitude. From my perspective the game worked fine, then they dropped this update and the game stopped working so it obviously seemed the issue.

Anyway I uninstalled and reinstalled the Redistrubitables but it still hasn’t fixed the issue, I still get the same error message except now it doesn’t say the missing file name at all, it just leaves a gap.

Loving technology right now.

1 Like

The flexibility and variety that makes PCs so great is what makes them so terrible. So much customization and personalization makes it incredibly difficult to make programs and games just work right the first time around. How do you test everything before release?

What will it be like in another 20 years?

I don’t know enough about programming to even have a clue what it takes to make something work right, but in my mind, I am picturing the difficulty to make a program work with different PCs, like taking a SATA cable and sticking it in a CPU socket, or RAM socket. They just don’t match, so a thousand little tweaks have to be made to patch them together. I feel like the interface between programs and the various machines somehow have to become much more modular.

It should not care if there is an Nvidia or ATI video card. Mac or PC. WIndows or Linux. 4k rez or 720p. It should be as easy to plug in a program as it is to plug in a toaster, TV, power drill or hair dryer. All of those items know exactly what the socket looks like and have plugs designed to fit perfectly.

When will programs and computers have exact plugs and sockets that match every time?

Funcom makes launcher that seemed to work pretty well on testlive. Then they dropped little patch, which broke for me, but not the majority on testlive. Then they made a patch for that and dropped it live, which worked for me again, but then broke things for other people in live. Some people this thing and some people that thing. Obviously the launcher is working for the majority, or they would have removed it. But it just shows how every computer is so darn different, making it so challenging to create a “one size fits all” launcher.

I remember the days when I worked in corp IT, consulting for large corporations and dealing with the challenges of massive PC refresh scenarios (replacing aged PCs with all new ones). The huge challenge was trying to get them all with the same internal components, so all the drivers, firmware and BIOS images would be the same. Made the lives of IT staff much easier when they could push down a single gold software image to all the PCs and know all those PCs would then work right.

Funcom has zero control over the hardware, so they have to find a way to get their code to work right on potentially millions of unique PC configurations. Not just one golden image here. Millions. “Dammit Sven, didn’t you test against the Thinkpad Butterfly keyboard with the 140 banana power commodore 64 CPU conversion??”

Bottom line, they can’t have enough randomization of configurations in-house to test and there aren’t enough people in TestLive, so it requires some pain in the Live launch to catch the remainder of the incompatible configurations and fine tune the launcher to where we all need it.

I like walls of text, now that I’m retired. Obviously.


Sounds like another incomplete update as usual Funcom. Here’s a launcher you really don’t need, it doesn’t work properly, we’ll fix it in an upcoming update. Repeat cycle. Sound right? Listen to the cries of your community and stop putting out new things that you need to fix, and fix your core game. It really would be to your benefit, not just ours. And before anyone says it, yes I know this is test live, but the point is the same. Stop adding and really start repairing.


Выпустили новою обнову, молодцы. :-1:
В игру Конан отлично играл больше года, а теперь вторую неделю не могу зайти в игру. Проверка файлов никакого результата не дала.
Скажите когда исправите ошибки или уже можно удалять игру с компьютера?

Всем добрый день,подскажите пожалуйста,в лаунчере нет строк “Сontinue” и “Launch” по факту подключения к игре из-за этого становиться не возможным! Если кто сталкивался с данной проблемой, подскажите как решить?

Sorry Its not a User Problem - The launcher does not update. Also an update in the actual start window (online, solo, mod settings) does not work. When I start an online game from my own Dawn server, everything works. Ergo must have messed up the update to steam. which would not be the first time.

The launcher does not update. Also an update in the actual start window (online, solo, mod settings) does not work. When I start an online game from my own Dawn server, everything works. Ergo must have messed up the update to steam. which would not be the first time.

totaly dislike the launcher,
sorry but why moving away from steam,
and why do i have now a launcher wich i cant repair over steam…

all i can do atm is start the game then… launcher then… nothing, running running running nothing happens… not starting a game, and every f…g mod update it crashes, dosent know the mod update does endless restarts without noticing the version is wrong, and after countless problems now this its not even starting the game… gosh…

problems with funcom live service since 2 years on my lapptop and now through the stupid damages Launcher i cant enter the Game enter any game…

the Funcom Live server was bad prgrammed, the Online page was… no still is badly programmed, and now this crap a launcher wich has no selfrepair funktion…

If your display scaling is more than 100%, try resetting it to 100% and running the launcher.

Many games use their own Launchers (No Man’s Sky, CIV6, BG3, Stellaris, etc…). In the case of the Conan Exiles one, it does definitely launch the game faster, but should you want to start the game like you did before, and as with most other games with their own launchers, just drop a shortcut to the exe on your desktop. It will launch slower (mine takes forever) but it does launch.

DRIVE-LETTER:\Steam\steamapps\common\Conan Exiles\ConanSandbox\Binaries\Win64\ConanSandbox.exe”

You can still update mods via Steam. That has not changed.