Game keeps crashing in new update

Conan Exiles, PVE - Conflict

Server: Official Server #7089 The Isle Of Siptah

Xbox: Xbox One S

Hi there,

Ever since the new update Age of Sorcery, my game keeps crashing before I can finish loading into this server sometimes. I can’t even access the Bazaar, the Battle Pass, and the Challenges section without it crashing completely. Sometimes when I try to start it after crashing it won’t even let me skip the cinematic in the beginning, which I found odd.

I tried it in the single player and had no issues. It’s just the server I’m having issues with.


Hello there @GuardianOfSouls and welcome to our forums!

Thank you for your report and for the information provided.

Regarding this situation, would it be possible for you to please provide us with a video of this crash occurring? Feel free to direct message me with a link for Google Drive (or an alternative platform) or a YouTube (or alternative platform) video.

Why do you guys always need video and more and more and more information. It’s happening to everyone on Xbox One S for sure. Game doesn’t load past first cinematic, reset the game get into it with massive loading issues, then crashes. Sometimes in the first hour, sometimes in the second. But a guarantee either way. Loss of items, thralls, building pieces, crafting stations whatever. How about some update on here or Twitter about you guys knowing there’s a problem and your working on it?


I have been trying all day and it keeps telling me it lost connection to the server. :confused:


this is happening everywhere, i have a 10 man party every day that this happens to everyone in the party, the game crashes when trying to open inventory, my game crashed 6 times in 15 minutes and each time i have to open it, close it to get the intro to skip when i reopen, and then if im lucky ill get an hour of playtime before it crashes again, now with this new update im lucky to even load into the game after waiting 10 mins from the last crash and loading screens.


Right, even me, i’m playing on the S series and it’s ok but i dont want to play more because most of my friends are playing on the one S and just can’t play, the game is crashing everytime they try to open they inventory, it’s just not playable at all and really, i think it’s not normal, people paid this game and now they can’t play with it !! How is this possible, of some consoles cant make it right then do like GTA online and just propose a Series x and s version instead of that ! It’s been more than a week now that my friends cannot play to the game and i’m myself trying not to delete it from my console everyday ! What are the devs doing ??? Seriously ?!


This should be the first problem they concentrate they brains on !! It’s happening to soooo much people i don’t even know why they dont do nothing ! Ps : excuse my english i speak french.


I’m pretty sure that the problem comes by the fact that players cannont change the mode between ‘‘performances’’ and ‘‘graphics’’ anymore since this last update, on screen they have grass, and many details that makes the old consoles crash, i just d’ont understand why dev’s have not try to put a mode with lower graphics to see if it fix this bug !! Really it’s crazy, people have paid more than 100$ to be the owners of a game and they cannot play with it anymore. I’ve never seen that on another game, they all propose updates for the series and let the ‘‘normal’’ game for the others.


I have this issue as well. Official servers seem to be broken. I get about 10-30 minutes of actual play time if I am lucky between crashes.

Somestimes load in just to crash again immediately.

I think it is a processing issue for populated servers, cause my private server runs better than Official.


Has anyone found a fix yet? This game is completely unplayable now. My clan used to log on daily and now noone wants anything to do with it after the update. I’ve tried reinstalling, soft reset, and clearing cache. No improvements just lots of frustration


My Xbox one keeps crashing it won’t let me skip the cut scene either I was really excited for the new update I’ve been hyping everybody in my family up for Conan for the longest time I think it’s a great game but it’s hard to say that one I can’t even get into the game and if I do I’m a role in the game will crash many of the bugs please fix also with not letting cut the cut scene happens to me is I may after actually get out of Conan go into a different game reloaded turn off my controller everything just to get past cuts in because it’s infinite


Anything older then the most recent systems no longer have the processing strength to handle tge game. I had same issues and upgrades from xbox one elite with a ssd to a xbox s and it fixed all the crashing and redering issues you all have been discribing.

i have the same problem on xbox one single-player and co-op whenever i open my inventory or a thrall inventory immediately crash whether it’s on performance or quality it crashes ethernet or wifi it crashes the only work around that i have found is to manage your inventory via work benches or chests or vaults or dead enemies


Everyday for a week or more now Microsoft even put the game for free for everyone with Live for the weekend and it’s unplayable. They obviously don’t listen to people to check and make sure the game is playable they just did it for the new update.

exactly before this update and patch everything worked fine minus the little bugs here and there and the whole fiasco with single-player being deleted in 2020-2021 then going to post on Twitter it’s live and free this weekend honestly this is starting to feel like the single-player deleted incident

It seems a lot of people are having this issue. Devs, please fix this as soon as you are physically able. I don’t want to rush you. I just want to be able to play without my buildings decaying. :frowning:


Has anyone provided the requested information?

it is amazing what can be observed by watching a video of the error/behavior vs trying to decipher the messages posted here. There are many platforms discussed and each one will have it’s own set challenges to research and de-bug.

i actually did make a video and sent it via YouTube mine was for the Xbox one single-player and co-op opening inventory crash

1 Like

Same here too. I have been playing this game for years! Then the update! Unable to load into my current base as i move and crash! Im gutted as our party had spent a lot of time and effort on it. Moved to another server and started again but the crashes keep happening. Im running through the ground not on it. I lagg then crash near bases and when i finally manage to get back on ive lost everything! So disappointed i just want the old game back!

1 Like

Me too. Stutters galore, especially when opening a crafting menu. It’ll freeze for 3 to 5secs. Yesterday it crashed 6x, I gave up and quit. Pop-ins, galore. I went to the Hunter’s Cabin(trapper’s??)in the Highlands to get the cookbook and thought I was lost. The cabin wasn’t there. Walked closer, it appeared then disappeared. I had to wait a good 5min for the game to catch up with itself. The game is far from stable.
Sound issues are worse than ever where parts if not all sound will go away. Some will lag so bad I’ll get death grunts 30secs after walking away. So many issues since the update it’s depressing.