Giant lorestone journey step not completing

A bug was posted from PS4 where these were not working and it was mentioned it would be addressed. I do not see it in trello (I might not have looked in the right spot?), so I thought I would repost it. I just went through a guide on their locations and well as using one of the map resources. I had already been to all of the posted locations, but I clicked them all again anyway.

No change. Still a step I need to complete.

Testlive dedicated server on PC

I have also experienced this on PC with both Giant-King stones ans Lemurian lore stones. I think that there are 13 each +/-.

I look forward to getting this fixed too.

Also, it is IMPOSSIBLE to get the Exploration Journey (discover all map locations) without the final location which is unreachable on Official servers.

On private servers: If you want the ‘Exploration’ Journey achievement, you have to ultimately teleport here: TeleportPlayer -305963 312069 88

If you are on private server, this Mod fix both of these: 1455594708
But maybe not on testlive.

1 Like

I was able to complete the Lemurian step though, with no special mods. So at least on Testlive, that one appears to work for me. I think I will take a look at the mod though and see how it can help for now. I love moddable games now. Best thing ever.

The Lemurian is fixed on LIVE too.

Hey there sirvink. Thankyou for taking up this cause. I have just recently worked with another forum user and modder Alex02 and a few others to try and unlock the reason why some Journey Steps arent completing. It turns out there are actually 5 Journey Steps which are at least somewhat bugged at the moment. However, some are completable under certain conditions. You will find all the said steps on the thread below. I am passionate about this subject, as Ive always seen the Journey as being the closest thing we have to a ‘main questline’. If you are looking to expand on your own thread, or simply wish to read our findings, you can view them on this thread:

Prior to this I started a more basic thread called ‘Journey Steps Bugged’ in the ps4 section. Between these two threads, Im sure you will get at least some questions answered. Good luck friend.

Ps- if you dont manage to get ‘Discover all of the Giant-King Obelisks’ to work, please do let me know how hey…?

1 Like

for the giant kings, I went to them all about 3 times and no luck, until I loaded a mod that would complete the step if I clicked on any of the tablets when all had been clicked already. The mod worked great. It also adds in the mummy, but I am hesitant to do anything with it, as Funcom is hinting it may very well have some work on it in the future, so I don’t want to potentially shoot myself in the foot there.

I didn’t mind using the mod for the giant kings tablets, since that was an obviously broken step, but with the mummy not having even been added to the game yet, it sure seems like lore they have been saving for a future update - something that could be really interesting. Who knows, maybe a big dungeon, bigger than something like the grove, full of mysteries, treasures and recipes? I dunno, but I am excited and hopeful.

The mod I used is: Bugfixes for Journey Steps.

Keep up the good fight!

Cheers sirvink. I have been informed that the Giant-Kings step is being worked on. So hopefully we will have a fix soon. As for the rest, much like yourself I have decided that it would be best to simply wait and see what happens for now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.