Is my PC getting too old for the game?

First, let me just say that I love Conan Exiles. I have most of the DLC, and have logged just under 4,000 hours on the game. As a survivor of stroke, I have dived into the worlds of Exiles and Siptah with enthusiasm, so I wanted to thank you for the fun!

I’m hoping that you can help me address a problem I am having with the game recently.

The engine is crashing a lot, either completely freezing the system or giving a 3D Device error. When I started playing - some years ago now - I was able to run the game on “Ultra” graphics mode, with other apps (media streaming service) running in the background. Nowadays, if I attempt to play on Ultra, it’s a matter of minutes before the game crashes, even with nothing else running in the background. I find that using “low” graphics mode mitigates the problem a little, but the program still crashes or reports a 3d device error soon enough.

My question to you is : Is my system getting too old to keep up with updates to the game and my migration from Windows 8 to Windows 10?

Gigabyte z75 gaming 5
Intel i5
GeForce GTX 680 Classified
32 GB Memory
Seagate SSD
Windows 10

As you can see, it’s an older system, but runs all of my other apps without problems.

Thanks for any help you can give.

1 Like

Hi,

  • First do not upgrade win 8 to win 10 but format and install a clean win 10.
  • Then uprade you graphic card to a rtx 2060 for example, work great for me ! :slight_smile:
2 Likes

The Windows was a clean install. And I’m not really in a position to buy a new GPU, hence the question.

Thanks for the speedy reply, though!

May be :

  • check steam integrity of game files
  • install conan again
  • update drivers with GeForce experience
  • stay in HD 1920 x 1080, ultra.

Good luck :slight_smile:

2 Likes

screenshot of it or it’s a an augery you’re asking, and it’s not really right forum for that

pretty much, pather point platform is ancient history, GPU is also bit dusty
that said since CE got settings reworked it got pretty heavy on CPU where shadows are involved, try lowering this setting, rest should be good on ultra/cinematic

Already done all that. Thanks, though.

“pather point platform”?

My system is even older, on i7 3770k 16gb ram, a cheap mobo that i could find to run a 1155, and a gtx 1060 6gb. I run the game in ultra for a year, and in the last updates things are messed little but, i could overcome it lowering postprocessing and shadows to high (note noticed much difference in game). I run on win 7 windowed mode 1900x1080, got between 30-60 fps and less than 30 only in crowed, or heavy builded areas (not building fault but of my poor profile). One thing i noticed recently is the memory consumption, that increase along the time, and some times lead the client to crash.

1 Like

that’s intel’s name for it, they like to give pieces of silicon a fancy name
regardless it’s EOL since Jan 2015
but I wouldn’t recommend an update just yet thou, too much shitshow on components market plus DDR5 transition makes it suboptimal thing to do, next year

Do you also have a integrated video card? Make sure the game uses the external card which I assume is the better one of the two.

1 Like

Thanks for the tip, Narelle. The integral GPU is turned off. I think it IS merely a case of my PC having slowly dipped below spec as time has gone by.

So far I’m having good luck by setting Conan Exiles settings to cap FPS at 60.

Now about 22 loads and only the 2 crashes mentioned in the thread there. This is a Funcom bug and not your system as far as I can tell. Quite a few people are having the same error. There have been quite a few others with the same problem.

As to weather your system is capable: if it was “fast enough” a few months ago then it should be still. If it were me tho, I would upgrade the video card if my budget were low… Maybe a 980Ti or a 1080ti. GPUs are coming down fast now (starting this week) and in a month or so used cards should be very affordable. The 3070 used, will likely be a good buy sometime in late July according to market aware reviewers. Check your PSU can supply the needed power.

If on the other hand you have a $1.8k ~ $2.2k budget then out with the old and in with the new as you can manage it. While most prebuilds are pretty terrible some aren’t so bad so there’s that too.

You and I could troubleshoot this in a few minutes. I think this is where your higher load times are coming from.

Please have a look in your NVIDIA Control Panel under the 3D Settings. If you limit your framerate there, or anywhere else outside of Conan Exiles, you can expect a crash in this configuration.

So, after an update, and testing:

  • Chipset: AMD X370 to X570
  • VGA: AMD RX590 to 6700XT
  • CPU: Ryzen 2400G to 5700X

Framerate capped at 120 FPS (was this before, but why? :rofl: ), now the settings are ultra/high (was medium and some high before), display refresh rate at 1440P set to 120 hz.

Got 1 crash so far. Which was a freeze, no warnings, no fatal error, nothing, only the game stopped. And since alt-tabbing ot CTRL-escing is this game’s worst enemy, couldn’t exit to the windows. After several keyboard smash, thegame sound started playing again, but that’s it, had to restart the computer.

why? I do it all the time, do you run it fullscreen or borderless window?

Fullscreen.
I just simply can not exit to the windows or switch to another task, because if I try to do so, the game music continues, but no switch, only black sreen. And if I try to go back into the game, it won’t happen, black screen. :laughing:

Edit: I was partially dumb, CTRL-esc works, only alt-tabbing gets the game to its knees.

CE does not like fullscreen, switch to borderless window

1 Like

A lot of help here, thank you, people.

Sadly - having tried the fixes suggested here - I have to conclude that it’s my ancient PC.

1 Like

VR headsets are still on the bleeding edge, and are good to measure up the performance matches.

The 1060 card is no longer at the front since RTX entered competition.

You will need USB 3.x board with at least 6 ports. All earlier setups are outdated.

Totally depends on the headset.

Quest II for example does just fine on WiFi alone - full spec, no lag, etc.

The current problem with VR headsets isn’t the tech… it’s the lenses.

But I wonder how that topic made it’s way into this thread?


Also 1660 is the most popular only because of office PCs and a buttload of poor and jobless gamers - but it was never at the front of anything. It’s a weakass card now and was at launch too.