Notum Dovvetech GUI 4.34

An important bit about editing the textures: while most image editors seem to default to 32 bit (RGBA) format (even if the alpha channel is left empty) when saving .png files, AO needs them in 24 bit (RGB) format so you have to make sure to use that when resaving, otherwise all edited textures will appear in game as solid purple.

Instead of the alpha channel, AO uses the pure green color (#00FF00) to specify fully transparent areas of the texture. There is no gradient/opacity, only fully transparent and fully visible areas.

thx to u .

Im a totaly newb at gui, and coding stuff …
how do I extract the uvga files with demoders gui compiler ?

I only wanna change some gui / overlay textures

@Honorbound would it be possible to have a setting in the command line that we can set for the mission window to be the same size as it is in the original GUI? Clicksaver doesn’t work well with ndgui and I really don’t want to have to use the normal GUI.

Also, the “daily rewards” window from RK6 doesn’t have any way to be opened in ndGUI as far as I can tell.

There is a patch for ndgui with a new button to open the daily rewards window

The mission window has no xml definition (as far as I can tell), so if it’s different in size when using ndGUI then it’s because the texture elements used to build it are different, not because the layout has been changed. Thus it’s not possible to have only that specific window look the default way since each texture is defined only once and then used in every GUI element that references it.

ndGU has been updated to a few weeks ago, that change includes buttons to open the new windows related to the new dimension. Please download and update ndGUI from the backup site added to the original post as the previous site is outdated since I lost access to it and cannot update it currently.

So the only way would be to change the texture element, thus changing the entire GUI?

I thought I used the newest version when adding it. I’ll give that a try and see if I get that button.
Edit: have the daily rewards button now, my fault. Thanks!

Yes, all of the textures that the mission window includes would have to be identified and reverted to the game default ones, and since many of them are used throughout the entire interface, that would mean you’d get a mutant GUI consisting of a mixture of default and ndGUI texture elements everywhere, so it’d cease to be ndGUI as such, and probably also break certain window layouts.

And if I went in and resized that texture to make the window the same size, it would probably break other parts of the GUI as well, right?

Actually, just decompiled the GUI and it looks like the AO client stitches the window together using several elements…I wasn’t aware that’s how that works. So I don’t think what I was saying would even be possilble. Thanks for the info Honor!

@Honorbound can u tell me how to extract the texture files of the gui overlay?

What theme are you using @Teeko? I‘m using ClickSaver myself a lot and haven‘t had any issues so far.

I haven’t had any issues either-- using dark mini or dark edge. I do yearn for a lighter color INSIDE the inventory, bank, & backpack slots. Dark items are almost invisible as it is.

After Saavick’s map this is the most useful thing there is.

1 Like

I use Dovetech Dark. Clicksaver rolls just fine(after you place the window in the exact right spot, which isn’t the very top left of the window anymore, its set in a fair bit due to the size difference). But clicksaver can auto select and accept a mission for you, and it can’t do that since the missions and the accept button aren’t in the spots that clicksaver intends them to be.

@Literary Agree, I lose items in my inventory, bank, and backpacks all the time. My only complaints are these two things :stuck_out_tongue:

@Awex a few posts back there was links to AO skil tool and Demoder’s GUI Compiler, both worked to extract the texture files of the gui

I know that we can’t move the cast bar, but can it be skinned at all to be more visible? Really freaking annoying that it is tiny and tucked away where I’m not looking.

I switched to the regular dovvetech theme which a friend is using. His clicksaver(same version as mine, I am the one that gave him the download for it) rolls, selects the mission, and accepts the mission. Mine does not. My clicksaver looks like this:

Requesting the mission:

Selecting the mission: (It’s trying to select the first mission, in the top left)

Accepting the mission:

Any idea what would be causing this? I’m using the new engine, 1920x1080, windowed borderless mode. I’m not sure if it would be a clicksaver issue or ndGUI issue or something else, since he doesn’t have this issue with the same gui and the same clicksaver.

1 Like

The mission window should be in the top left corner :blush:
Screenshot from the ao-universe clicksaver guide:

Something appears to be very inconsistently off there with clicksaver itself. It points to the request button properly, but then expects the mission icon to be higher and to the left, and at the same time expects the accept button to be a lot lower and to the right even from where it is when the window is already lower and to the right than where it should be. It would only hit all the buttons if the mission window was a lot taller and wider than what it is, but if I use the mission icons as a size reference (since their size can’t be changed by a custom GUI) the base size of the window looks about the same, not 25-30% bigger in both directions as clicksaver apparently expects.

Is there a size override/offset setting in it somewhere that you may have adjusted and forgot about, or using a wrong version or anything?

Nope there is no size adjustment. Click saver expects the window to be all the way in the top left of the screen. I had to put it where it is now for it to request missions properly. This is the most recent version of cs, downloaded from aou about a month ago. Could it be because I use the new engine?

Do you have any windows scaling enabled? That might mess it up.

You could try disable scaling on both AO and Clicksaver like so:

So,I disabled the scaling the way it said and that did not work. However if I unchecked “High DPI Scaling Override” that worked, but my AO looks like this:

. So, double edged sword, but luckily it wasn’t ndGUI’s fault, thank god! Appreciate the help, Saavick.

1 Like