Ongoing performance issues with current testlive

In my case all of this is happening in singleplayer (unmodded) testlive.

In addition to the previously reported performance issues when loading into the game (see here for an example), I am experiencing new performance issues with the map screen.

Specifically - when I press the key to open the map screen, there is a delay (a couple of seconds) while the game ‘decides whether it feels like it’ - this is not present in even heavily modded games on live branch.

I’ve also just had the testlive client crash on me again (after only around half an hour of testing) - normally I get around 6 hours before I have to start risking crashes and have to think about re-booting.

As noted elsewhere, none of these issues are major in themselves, but they appear to indicate a significant degradation in performance between the live version and the testlive version. (Crashes may not be an issue, since testlive may be unstable because it is unfinished, but noticeably worse performance seems to indicate a problem.) My machine is within the recommended specs for the game and I am having problems with basic elements of performance, which suggests the problem may get far worse for those on lower spec machines.

I hope Funcom will take a serious look at the way that the current testlive patch is performing and hopefully find a way to bring performance back up to similar levels to live branch.

Edit: This thread contains some further information that looks (to my untrained eye) like it may be performance related as well, also on testlive. Maybe @Papatango0269’s findings could provide the team some clues as to what’s going on:


The pause before loading the map screen is happening to me too. I’m glad you mentioned it.

My issues loading into the game have stopped. At least in the last day I haven’t loaded into my base stuck in the foundations.


Interesting that the load in issue has stopped for you - if anything it was worse for me yesterday - dropped me through two ceilings and into the water beneath that part of the base. Still, I suppose that could be seen as a positive - at least I wasn’t stuck in anything :slight_smile:

So I’m not the only one having these issues. I thought perhaps it was just me because my computer is aging. That said it is within recommended specs but I have this map issue as well as a great deal of stuttering in my single player testlive game.

1 Like

It’s good to see this seems to be happening to more than just a couple of us - I’ve also heard from a youtuber who’s experiencing the same issues - like everyone else, he assumed it was just him, lol. Hopefully these issues, minor as they are, will help lead Funcom to whatever it is that is underlying the problem.

Hey all, rather new to the game, presently I am able to play only on the testlive version and as with the OP, I have several issues. Though after the latest patch, my game is less “buggy” than him.

As for his original report, which is being stuck when loading the game, the issue still remains, in my case, only when it comes to foundations, and every single time.

1 - Stuck

2 - In this example, trying to climb, crouch, move does not help, because I have nothing to hang on, so I was forced to demolish the foundation I am standing on. Problem with this, sometimes other structures will also follow in the destruction, a wall with anything hanging on it for example, with a chance to loose some valuable assets.

See how hollow is the foundation when getting demolished? That’s the source of the issue. The character, when spawning first, will stand on the ground, then when the structures appear, the hollowness has no collision to push the character upwards. I used to have the same issue with ceiling tiles, but the last patch solved this.

3 - Spawning on a ceiling tile, works great.

4 - Low foundations, no issue. It all depends on how elevated is the foundation, when it’s close to the ground, not higher than your calf, it has no issue.

If the collision box of the ceiling is added to the top of the foundation may be one way to fix this…or add some floor tiles that could be directly applied on the top of a foundation. I own no DLC for now, are there any specific floors?

Until then, I always get on on the cow floor before exiting the game.
This old mod still works perfectly, in case you get stuck and you do not wish to demolish anything, it can teleport you without the need to be admin.


1 Like

I’m definitely still falling through ceilings as well (to wind up in the water, as I have the past two days on logging in, I have to fall through two of them) - and last time that I got stuck in a foundation, I was somehow able to climb free despite having nothing to climb on (I just hit forward and jump a few times each, and it seemed to work…) - once again we seem to be experiencing slightly different versions of the same situation, which I find really interesting. (I’m almost more curious about what exactly could cause the differences in our experience of the same effects than I am about a possible solution :wink: ).

Unfortunately, there are no specific ‘floor’ pieces in any of the dlcs that I can think of - I think vaulted ceilings are the only strictly new shapes that have been introduced that way.

I still get the feeling that the issue I’m experiencing is entirely related to the building itself not appearing until after I have fallen through it - the character enters the world hanging in space, then begins to fall and only then, a couple of seconds after the game has started does the building appear above me. In your example with the lower (calf height) foundations - is it that you appeared directly on top of them, or did you appear at ground level and then get ‘pushed’ back up to the correct position when the foundations ‘appeared’?

Edit: Interesting - I just tried another experimental login, because I remembered I logged out this morning on a foundation rather than a ceiling tile. (Actually the exact same foundation that I have a screenshot of me fully trapped inside it on the other thread.) The base still spawned later than I did, and I began falling, but when the base spawned in, this time it ‘pushed’ me back up to on top of the foundation. The only thing I can come up with is that it felt like the base arrived slightly quicker than it did this morning (when I fell all the way through) - so maybe I didn’t fall ‘deep’ enough to become trapped this time? I’ve no idea why the exact same structure, unchanged, on the exact same testlive version would take a different length of time to appear in sessions a few hours apart…

1 Like

Yes indeed, it is interesting to see we have similar issues, but how differently they apply. I have read that some zones are presenting some extra challenges, from your original post, I see your base is in the south, while mine is presently in the highlands…I have an outpost there, I’ll make some tests and see if it reacts differently. I have a good rig, with a RX 2070, the delay for the structures spawning is rather very short, about one second.

On my ceiling test, the character appeared directly on top of it. In the two floor buildings, sometimes she falls through, but she does not get stuck anymore as it used to be, she gets pushed up on the ceiling/floor.

As with your edit, it reminds me the latest update in No Man’s Sky few month’s ago…ironically called “Foundation”. When logging in the first time, some bases where having this type of issues, more severely (two of mines even crashed my game), than the following patch made some individual progressive adjustments, so when showing up again in your bases, the game recalculated everything, my two bases became usable again. Maybe it’s something similar here, maybe it will get better with time. Curious to see if it will be your case. Seems it happened to me as well, on the other post we had together, I could not reproduce some stuttering because the game ran rather smoothly, magically.

This is still an issue anyway, because some players may loose some assets if they get trapped and are forced to demolish. I also got used to go outside before exiting the game, and I have this teleportation mod to help in case I get caught.

Will test in the other outposts, I will let you know by editing here.


1 Like

Good thought about possible locational differences - I’ll give the highlands a try tomorrow, see if it changes any results for me. In case it makes any difference, my current base is on the line of J5/J6 (supported above the water by columns of foundations) - the direction of the player arrow on the map below indicates the approximate course of the supported causeway back towards land.

Logging in to grab the map shot had the same result as in my edit above - the building definitely loaded quicker than it was managing this morning, which does add further weight to your theory. I’ll have to try logging in and out a few times tomorrow, see what difference it makes, retry the different surfaces etc. You’ve definitely got us narrowing in on something :slight_smile:

Very, very interesting. What this probably means, your NVidia shader cache is building up, so next time you are in the same region, the CPU does not have to recompile everything, hence, less stuttering, faster loading, if you have a good hard drive (SSD M2/AIC/U.2 types). Yeah, this must be it, why I also have better performances now.

I did a test at my Southern base, which is not really far from yours,

2 layers of foundations, in the river, and I spawned right on top of it, no issues. You also see the size of the outpost, it’s not big, but it has all the workstations and thralls, and most buildings, this was my first spot when I started the game under my first login…and it loaded in a fraction of a second.

If you build one in the highlands, if that shader’s theory is right, you will have difficulties in the beginning if you have not explored the region thoroughly, but after few sessions, all should go smoothly. Here is my location, for single player, it’s a very good spot, terrain is lightly bumpy, no need to build foundations everywhere, lots of resources (iron, coal, wood, boars, rocks, etc…)New Asagarth and its forts nearby to farm some thralls, and a lake to the east for fishing. Only minor issue, the grass showing up your houses if the foundations are not high enough as I did. In the F9:
Main Base

Cheers mate!

1 Like

Yeah, the game is on an M2 drive - so it sounds like a good possibility. Presumably the shader cache will get cleared each time the machine restarts? If so, I should see a longer load in time the first time I try it today, with subsequent improvement later.

I don’t think I’ve been to the highlands at all yet in this test game except one brief moment en route to testing something at the Black Keep - so that should also be a useful test. I’ll drop a building in somewhere near yours and try a few things. (Yep, you picked a much better area of the highlands than I did in my first playthrough - I was in the far east corner overlooking the lake with the big island - very pretty but incredibly inconvenient for going almost anywhere…).

I’ve got a few other things I’ve got to get done this morning, then I’ll jump on and give these things a test.

Thanks, this seems really useful :slight_smile:

Edit: Today’s testing had some interesting results - not really sure if they support the cache idea or not:
I logged in and out multiple times at the southern base, then flipped up to the highlands and built something close to where you are and tried the same -
In several cases (at both locations) I fell through spots where I didn’t fall through on a previous login - overall load time seemed the same to the naked eye, but presumably was a fraction longer in the cases where I fell through. At the southern base nothing I tried got me stuck in the foundations, but I did still fall through ceilings. Load times looked consistent from first login until last (and matched up in the highlands even from the first login).

Height of foundations in the highlands did make a difference, seemingly matching pretty much exactly what you noticed -
at chest height I fell into the foundation (but for some reason was always able to wiggle free)
at waist height I fell in and got stuck
at knee height I fell in and could easily jump free
at calf height I did not fall through at all.

However - one key difference was that at each of those heights I got the same result with a ceiling piece as I did with a foundation.

It’s all very strange, and I’m frankly mystified about some of the differences in our experiences. At this point my best theory for the differences between my own tests in the same load in location is a combination of mild fluctuations in load times (maybe even nothing more than temperature differences or something). As for the differences between you and I, particularly the foundation vs ceiling difference - maybe there is a fractional time difference between foundations and ceilings loading in - too small to make a difference for my slower 1060, but perhaps just enough for your 2070? It’s about all I can come up with…

Thanks for all of this - hopefully we’re finding something that can help the team figure out what’s going on :slight_smile:


I could use some help. My character is stuck inside the floor I can’t get out. I guess I could destroy the floor but I’m hoping I won’t have to do that. I’m afraid a portion of my base will lost stability if I do. But yeah things are definitely getting worse for me if this is any indication.

I had to use admin to get unstuck. But yeah stuttering is pretty bad for me in game. I notice everytime it stutters clothing physics glitches out as well.

1 Like

I’ve been getting the delay opening map on our private live server so I don’t think it’s related to test server

just got started for the day and now getting constant rubberbanding… almost like i’m trying to run through a wall… but there’s no wall… this is the first time i have had this problem. stuttering is a major issue. i even logged out… fully closed down the game and restarted. nothing helps… i’m even running on med. setting with a 2080… so i know it’s not my pc…

Have you tried in singleplayer? (I’ve not had that issue, with only a 1060 on high - but then you also didn’t have that issue till today, so me not having it doesn’t necessarily mean anything). I’m just wondering if it could be anything to do with the server, or if there’s a way to rule that out?

Whatever the case, the more reports on these issues while it’s still in testlive, the better :slight_smile:

(On the subject of which - a member of the community team has acknowledged a related bug thread, and has agreed to send this thread to the team along with it so they have as much seemingly related data in one place as possible - so hopefully they are (or will be) looking into whatever is going on with these performance issues.)

Edit: @Ishinaia - interesting - yet another different experience - for me there is a noticeable difference between live and testlive (both in singleplayer) - seems we’re all getting slightly different variations of the same sorts of effects. Beyond me to figure it out - I’ll have to hope our reports help the devs find whatever’s going on.


hopefully it’s kinda insane… i’ll jump over to single player and see if i get any issues on it… honestly hadn’t thought about that… just in case anyone wonders i am playing on the official testlive US pve server

edit: so i just tested in single player and was able to start getting minor rubberbanding after building a base and putting various crafting stations with thralls… so it seems to me that placeables with animations… are a good area to start looking… i will say also though it’s def. a lot worse on the server so part of it could be server related and the server may need a restart as well

1 Like

Hey there,

Thanks for the feedback. We’ll poke our team to see if they can reproduce these performance issues on our end.


wanted to give a small update from what i have seen. it seems i get the largest perfomance drop just before the “false sandstorm” comes through. which seems tohappen the first time anywhere between 2 to 5 min after i log on. the last few times i have been on i haven’t gotten nearly the problems i had when i first reported my issue, so server resets may be needed a bit more often. (don’t know how often they currently happen)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.