Purge not spawning on single player

Game mode: [Single-player]
Type of issue: [Bug]
Server type: [PvE]
Region: [SA]

So I was playing on single-player without MODS for quite a while and after my purge bar was filled, I noticed something wrong was going on as it never took so long for a purge to spawn. I looked up every information I could to make sure everything was configured right, used all the admin commands I could to try to start one and still nothing. Tried in and out of a clan, not worked. Tried with the regular server settings, nothing. Made sure that minimum players was set to either 0 or 1, and when the restrict time box was checked, I configured the time to correspond to the one I was playing.
Here is a list of the commands I used.
all of which are working fine.
After that: StartPlayerPurge,
StartPlayerPurge Exile_Purge_Wave1,
StartPlayerPurge Scorpion_Purge_Wave1
Those 3 didn’t do a single thing. Even used SLOMO 200 to fast speed time for several in-game days and still no purge spawned. The purge bar remained full.
Afterwards I went to the testlive servers as it released a bunch of bugfixes and it didnt work there either.
I found a post with the same issue, where the guy mentions he did a fresh reinstall of the game and it worked, so I tried that, still with no success.
I didnt get any entries on the event log, but when I tried the command StartNextPurgePhase I got the entry below (which I’ll add to the screenshot)
INFOL_DATAERROR: AI: [BaseGameMode_C_0] BaseGameMode::ASyncSpawnNPC has not been able to attempt a new npc spawn for a long time. Forcing a new spawn.
Still nothing happened.
I’m pretty sure I tried everything. No Mods, New Saves, All codes I could find, fresh reinstall, all purge server configurations…I’m out of ideas.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Create a single player game on normal conan or testlive
  2. Build a base
  3. Use the admin codes provided above to start a purge
  4. See the purge not happening even after a long time waiting

How big is your base? What material have you used? What location?

First base was a small one near the Darfari Capital, around 15 structure sandstone blocks with lot’s of stations, 1 animal pen, 1 stable and 2 wheels of pain outside. The others I’m testing consists on a 2x2 sandstone house near The Sentinels, near the first river.
As I saw your reply I added 150 Black-Ice blocks to this 2x2 base and tried again. First attempt, nothing happened. Second attempt I’m getting the horns and notification (picture below) that a purge has been defeated. If I repeat the startplayerpurge command I keep getting this notification but the purge bar remains full and as I wait at Slomo 200, no purge is coming.
Still no entries on the event log.

Tried once again 150 Aquilonian blocks near Sepermeru. This time the purge spawned!

By the time I reply, you have figured it out. It appears that there is some building score requirement to even trigger the purge. Then depending on your location, there might be further complications like the purge not being able to find spawning locations (happens often when there is some water). It is a bit hit or miss with the purges.

I had some post about it some time ago, I am not sure whether the numbers are still accurate but may explain what you are experiencing:


Couldn’t have done without you! Thank you very much. Now back to kill some exiles.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.