Purge/Purge Command no longer working

Game mode: [Enter game mode here: Single-player]
Type of issue: [Enter one of the following: Bug]
Server type: [Enter one of the following: PvE]
Region: [Single PLayer]


I am currently only playing single player and have set my Purge settings fairly low to make them more frequent. Previously I was using the admin commands to spawn one. Since this latest patch (which I love FYI) I have not encountered a single Purge naturally and am unable to call one using admin commands. I have seen this issue posted in numerous places but as everything was working fine before patch and now not after I thought i’d share.

TLDR
Single player server
No Mods
Purge not working was working before
Purge Meter Full
Admin Commands not working
Working fine before patch


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.Purge meter full, no purge
2.Admin Command 'StartPlayerPurge" not working
3.No Purge
4.

Could you check the purge settings specifically: time restrictions and minimum players online? After the update our server settings switched back to 3 players needed to start a purge and we had to re-adjust them.

1 Like

I checked those and adjusted a few times.

Purge Enabled
Level 3
Delay 5
No Restrictions
4min Prep Time
30min Duration
0 Online Players Required
Allow Building On
Trigger Value 10000 (Changed from 100)
Update Interval 1

Hey @Boxman61

Before we relay this to our team, could you let us know if you’re playing with any mods installed?

1 Like

I’ve played around a bit. I was unable to start a purge on single player by using the admin commands, no mods. However, it worked as intended on my dedicated server. Normally when you use StartPlayerPurge command, you get an entry in the event log: “A purge has started for …” Then shortly after you when they find your base, you get the actual horn warning and the timer appears. However, in single player I am not getting this entry when I use the command.

I have recently installed the mod Kerozards Paragon Leveling - A Multigun Refresh - v2.2.5
but I have tested this with and without the mod installed. In each case, the purge does not happen via normal methods or admin commands.
Once again this is strictly single-player gameplay
Thank you Narelle

thank you for your assistance

Since Narelle is reporting it’s working on a dedicated server, you could set up a solo server using the Dedicated Server App Launcher (even temporarily) to see if your specific issue is also resolved on a dedicated server. Would help confirm if this is an isolated issue to Single Player.

Edit:

Just tested it myself, the admin commands in Single Player does work. It’s the same situation when I created the documentation on the Purge during a testlive period. To quote myself

This command will start the next available Purge. It does NOT happen immediately after typing this in. It will initiate on the next server check.

Note: You will know if this command worked correctly if you look at your Purge Meter and notice it has emptied. If it has NOT emptied, try again as it sometimes it took me two attempts to get it to initiate.

Original post is below

I was able to initiate the purge with the admin commands today but on a dedicated server. You do have to make yourself admin before using commands. I think you already know this but you didn’t specify that step in your notes.

Thank you for all the suggestions.
First off Yes I am set as admin but I have made that mistake before so I appreciate the tip.

Further Details-
So last night I allowed my purge bar to fill and waited around for several minutes. I also used the admin commands to initiate the purge with no results. I am aware that there is a delay due to server check but I counter acted this via alt+tab into youtube and/or doing some work. I sat around for roughly 3+ hours last night repeating the command and waiting with no result. I have also input the “StartPlayerPurge” multiple times with short pauses in between and my purge bar has remained full.

I will try to set up the solo server in a few minutes and report any changes

I’ve tried to make it work on single player and couldn’t. What I did:

  • Create a small base with sandstone foundations.

  • Fill the purge meter.

  • Make sure online players were set to 0, tried with 1 later as well. No restrictions to the time.

  • Use StartPlayerPurge - no entry in the event log, meter remains full, tried multiple times, nothing happens.

  • Created a clan. Repeated the steps above. Nothing happens, no entry in the event log, purge bar remains full.

  • Tried emptying the bar and filling it up again, still nothing.

  • Played around with the settings: enable/disable purge, reduce/increase delay. Both from in-game window and the .ini with restarts in between. Nothing. All with admin rights.

Logged to my server, made myself an admin, filled the purge meter, used StartPlayerPurge. I’ve got an entry in the event log, the purge happened shortly after. I ended the purge. Filled up the bar, used again StartPlayerPurge, I’ve got the entry, a few minutes later the purge happened.

I am not sure what I do wrong in single player @Multigun :confused:

2 Likes

Finally got the server up and so far the situation is exactly the same.
Use admin commands “FillPlayerClanPurgeMeter” then “StartPlayerPurge”
waited 5+ minutes with no response and purge meter remained filled.

Repeated command multiple times.

Perhaps a fresh install? or file verification?

StartPurgePlayer, or StartPlayerPurge? You typed both in your test feedback :stuck_out_tongue:

Unknown, I got it to work first try. ServerSettings.ini is default, as I just recently allowed the game to create a fresh one in the last update by deleting the old one and starting up the game (if that matters).

Edit

Just tried it again, worked first try again.

1 Like

Hit “StartPlayerPurge” twice within a few seconds if the meter doesn’t empty. A full bar that empties means a Purge will trigger on next server check. Once it’s empty, you can use Slomo (insert number here) to speed up time.

Might as well try a file verification, doesn’t hurt. Also for funsies, make sure the game is using a new ServerSettings.ini as I described in my response to Narelle.

2 Likes

Sorry:
image

This is what I used, the command is correct because I didn’t actually type it but picked it up from the console. I will edit.

EDIT: I’ve tried hitting up the command up to 5 times, purge meter remains full. I haven’t tried verifying (because it worked on my server) and deleting the ServerSettings.ini.

What I’ve tried is to restrict the purge time to 0001-2359. Reduced the delay to 1.

I will try verifying and deleting the .ini a bit later.

1 Like

Deleted the ServerSetting.ini and reset it to default and verified files. Same issue

Here is a video of what I am doing encase there is something fundamentally wrong
www.youtube .com/watch?v=JanibHu23_U&feature=youtu.be
(link broken up to make it postable, sorry if that’s a violation just trying to figure this out)

It’s just strange because it was working and then suddenly stopped

2 Likes

Hmmm, dunno, out of ideas. Doesn’t make much sense why it works for me in SP, works for Narelle on a Server but not Single Player, and doesn’t work for you at all.

2 Likes

Well I appreciate the effort and really love the mod. Going to do a full reinstall and just see what happens

Fresh install seemed to work. It was a pain recovering a lot of my stuff and still lost a lot but purges are working again.
Thank you all for your help!!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.