Server Login Problem

Several people including me have been having trouble logging in. We get to the character screen and select a character and then the loading bombs out to the user name/PW screen. It says it might be the servers are down but that is not the case. This has been happening off and on for a week.

I suspect the server is at capacity and is bombing out or the number of active accounts exceeds some setting.

Dunno says medium load, should be room

1 Like

Looks like you have the same problem i had. Also some other people: and

Reset your router first, if this doesn’t work try this here out:

I had the same issue 1 month ago . Try to log in with some other internet connection, your cellphone or from some relatives-friends connection. Or you can try some VPN, most have a free trial version. [(Don’ t want to advertise but this VPN worked for me, some others i tried didn’t work. (So you don’t have to search around to much)]. If you can log in from those other internet connections, then you maybe have some kind of problem with your home internet connection. I don’t know what this problem really is but i think it’s some kind of communication problem from your internet providers server to the Funcom server. Anyway, i changed my internet provider and now it works. Unfortunately it seems to be the only quick solution to this problem.


I have that bug too. I fix it by changing VPN servers and waiting out for 10 minutes.