Texture and asset loading issues after 2.4.4 - PS4Pro/PS5/Base PS4

Lag is getting significantly worse on Siptah. Idk what’s happening, but I’m dying due to it now.

Hello Dzonatas,

after examining your image through my magic magnifying glass, i was able to identify the fault -
it is definitely Thor who got lost in the universe and is angry because of it, and with his mighty
hammer he created fog and turned the country into an ugly country!

I hope i can help funcom through this incredible discovery to eliminate the problem that thor is,
but be careful of his hammer!!

tho_r

… hard times, need a little fun, Yumi :slightly_smiling_face:

9 Likes

Exiled lands are pretty terrible right now. I went on single player/co op on siptah and was presently surprise. It was running smooth and outside of the contrast being a bit to high it looked great. However, after just a few days I started noticing lag, texture issues and invisible npcs. What in the actual F##ck is with this company? Hard to believe they didn’t see all of these issues in testing.

2 Likes

If you really want to be surprised, take a look.

I play on a PS4 Pro, hard wired, external SSD, internal SSD, and the actual game disc.
We are also on an official server.

2.3 slowed the render time for builds. It was fine, but I had to wait a minute or so for the base to fully render, or at least for a door to appear.

2.4 slowed it even further. This is 5 minutes after I arrived

For the past week, I haven’t done much online. I have just run around a little. Several times I have run up on the edge of where the map has yet to render. I did it twice on horseback, so I tried to just run. It didn’t help.

This is on the river running east to the Sentinels

This is running west towards the Ward Towers

Not only am I waiting for buildings and the actual freaking map to render, NPCs aren’t rendering. I have been killed 4 times today. I’ve never died four times in the same month. The people I play are usually surprised when I say I was killed.

Three times, I was pinned against some structure I couldn’t see, attacked by NPCs I couldn’t see. Once, at the south jungle obelisk, I went to fight the panthers, and my axe never appeared in my hand. I was holding my hand out like I had it, but it never appeared, and I couldn’t attack. Add to that the panthers glitching around from spot to spot without moving, and 6 bleed gets to be a problem. Even the gorillas got in on the stutter moves.

The game also freezes whenever I run up on a build. I have regained the ability to move just in time to be attacked by things I normally ignore.

I lost a thrall from a build. She was stationed inside. When I went to investigate, all 5 thralls from the inside were outside, having moved on their own. This is happening all over the map. I find thralls have moved to new locations.

@Hugo @Ignasis , this is a serious issue. The last patch renders the game no fun. If I’m not having fun, I’m not playing. At best, I can run to my bases and reset the timer, but that’s it.
I will do that because our clan has almost three years on the server. We have amassed quite a bit of stuff.

I hate the overuse of “unplayable”, but this last patch brought us to it.

3 Likes

Welcome to the party lol. Having all the same issues. 4 or 5 tries to equip a weapon, tool or shield is the latest one I’ve come across. For a few days I was able to ignore most of it because I was just experimenting with the new building pieces from siptah but once I got out into the world and started “playing” the game it truly is a unplayable mess right now.

Merged another thread into this one dealing with a slightly different outcome of the same issue. Also changed the title of the topic to better identify the problem.

To summarize, the issue seems to stem from a bottleneck on loading assets (being textures, models or geommetry). It does seem to be worse on PS4Pro and PS5 systems, most likely due to the enhanced settings for the Pro model, which the PS5 also inherits. Installing on an SSD (or a PS5’s internal storage) alleviates, but does not stop these issues, especially on Pro and PS5.

These are the issues now being looked into. There’s no ETA we can share at the moment for a fix, but at the moment this sits as the top issue in terms of priority for PS4 internally.

6 Likes

In the meantime, you could make the wait more happy by publishing the hotfix with the problem already solved internally of full nudity😅

1 Like

That issue is solved and coming with the next patch. Unfortunately, pushing patches on PS4 (and Xbox) is not as easy and immediate as on PC. But it is coming.

6 Likes

May I suggest adding a sticky post with details of what’s being addressed or solved in the upcoming patch currently or to be soon in the certification process. And also issues that are being looked into for future patches. It’ll help with a lot of the confusion and repeat posts here.

2 Likes

What about standard PS4s, non-Pro versions? I only ask because you only mention Pros and 5s in this statement.

1 Like

Thats great that they actually Tool a high prio in this well done!

As someone asked, will this patch solve the issue for ps4 aswell as the Pro version?

Thanks!

1 Like

Yep, same thing I deal ALL the time. It’s beyond frustrating. I play on a standard PS4.

2 Likes

Have the team given a date for patch?

4 Likes

Because there are only a handful of official Siptah servers in the US, our groups decided to get our own. I can say it runs much better with 10 players than 40. However, there are times when the invisible NPCs show up, but usually only for 10 seconds at most. The problem that occurs the most is my screen will show an animal or person frozen in place/walking away while I am attacking them. They aren’t doing what is shown, but are attacking me. I just can’t see it. When the game catches up, I am either dead or standing over their body.

On official, everything is invisible for up to 5 minutes.

1 Like

Ps4 is unplayed, patch died this game

1 Like

When i look at this there are many, many people complaining about issues that basicly makes the game very unpleasent to play.

Funcom came with a statement that they have found the issue with the laggy game and visual issues, and that they will sort it in the next patch and thats good news, But to just say that patch xbox and ps4 is not at easy as PC dosent really cut it.

Which state are you in at the moment, is the console patch completed, and awaiting approval from MS and Sony?

Or have you recognized the issue, but havent realy sorted it out?

You need to keep us in the loop and have us updated, You cant just say “its not easy to patch” so shall we wait 1 week, or 6 months until the patch could drop?

Thanks

1 Like

Our latest status update about this issue can be found here:

1 Like

@SquashEm Thanks for the video. It matches the results of our investigations More on that on the last paragraphs. :point_down: :point_down:

@speedice That also seems to align with what we’ve finding out through testing. :point_down:

We’ve been testing this collating it with other reports we’ve received on Xbox (in particular One S models). The issue at hand seems to be caused by some out of memory issues and it is mostly happening once the database (savegame) reaches a certain size/ complexity. Meaning, those who have just started playing on singleplayer or smaller servers start to find this issue a few dozen hours into the game, while in bigger saves, private servers databases and official servers, this issue can manifest itself right away due to the amount of assets that needs loaded in.

That’s what we’re now looking into and trying to squash. With 2.4.6 we’ve added more optimizations that will mostly address the hitching/freezing also reported on consoles, but for the memory issues, we don’t have any ETA we can provide at the moment.
Once again, and for clarification:

1 Like

Game mode: [ Select one: Online official]
Type of issue: [ Select one: Performance ]
Server type: [ Select one: PvP ]
Region: [ EU ]
Hardware: [ PS4 pro ]


Bug Description:

NPC’s and players are often invisible. The attack noise for Human NPC’s is the rocknose sound effect. Other sound effects take sometimes a long time to play, maybe 10 seconds after you jump your character makes a noise. The graphics are awful, the far background looks terrible. The water effects are dreadful. Buildings and bases take a long time to spawn in, even small buildings. The loading when respawing and teleporting has increased a lot.


Expected Behavior:

The game to look and perform and least as well as it did before the patch and not worse!! .



Steps to Reproduce:

*Load exiled lands and be disappointed. *

5 Likes