Ubisoft Uport fail running Conan Exiles

So here is the thing, I was using Uport and Steam at the same time to run 2 instances of Conan Exiles on my PC.
Apparently Ubisoft merged with Uport and now you can only run Ubisoft games there.
I am wondering if anyone knows another Software Launcher that will run Conan exiles without trying to go thru Steam. I tried about a dozen third party launchers, but they all still try to open the game using Steam.
Any help would be appreciated, as I spent all night creating a VM on my PC and had nothing but problems with it, so I deleted it.

You mean Epic Games correct? They do run their own instance of CE, but that means I have to buy another copy on the Epic Games website.

So yes, I did buy another copy on Epic, lol. 39.99 - the most I have ever payed for one. I bought my original on presale for 8.99, and the other copies on a Steam weekend sale for I think around $15 each.

Not sure why I am so brain dead about this, GeforceNow worked perfectly, I just forgot I used it before. I just had to find @Frillen s post he made about it again.

1 Like

You mean this post :wink:

I still do it the same way and works fine for me to do the Add-to-clan thing :grin:

Btw my wife would be very much surprised if I was a she, however these forums don’t show gender of members, so yeah I could have been a woooman :joy:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.