Unable to connect to server

I have been playing on an unofficial server with some friends.
Yesterday something happened and my connection to the server was lost.
Since then I have been unable to connect except for once, and that was after hours of trying, failing and troubleshooting.

I have spoken to the admins of the server and they tell me there is no problem on the server side.
Everyone else on the server can connect, just not me.
I can connect to any server except the one I have been playing on.

I keep getting random errors when trying to connect.

  • Failed to join requested game.
  • Authentication failed.
  • Your ping is higher than the maximum allowed(Max is 350, I have 159)
  • On direct connect using IP and port, I randomly get “Connection timed out! Could not find server”, right after the previous attempt that got me a different error.
  • And a number of other errors I don’t remember.

I have been working with the admins trying to troubleshoot the problem.

  • I verified my game files multiple times.
  • I reinstalled the game(deleted everything including registry items).
  • I restarted my computer
  • I reset my router.

We are suspecting that something is interfering between my location and the server.
So now I am asking the community here in the hopes that there are someone with knowledge and expertise in the area that can help.

Hi @Bansheedragon and welcome!

I do not know if your problem is the same, but your description sounds very similar to this thread (very recent):


Its OPs official VS your private server but as said there are similarities.

If you will, please look at the suggestions and report back if any made some difference

Only two things I could find that I have not tried that was changing the ping setting in steam and uninstalling Geeforce Experience.

But the problem persists, I cannot connect and the error I get is different each time until it eventually settles on “Connection timed out! Could not find server” on a direct connect.

Did you try to connect to another server (official with low ping)?
Also per your answer I will presume you also tried flushing DNS and verified that you connection is good.

Suggestion, to narrow down options from Computer/router/modem/ISP:
If you have another computer in your network capable of launching CE, would you be willing to install there and see the results?

Yes I tried to connect to an official server and I had no problems connecting there.

The DNS flush I have not tried.
And I do happen to have another computer I can try it on, if I can get it to run on it due to performance issues with it.
I’ll look into it and see what happens.

What part of the world are you located? Who is your internet service provider. You mentioned that your server is an UNofficial one. Is this a private server that is hosted through g-portal?

I have had difficulty for the past two days. More trouble yesterday. Only one single disconnect on Monday. I have not yet tried today. I had a similar experience where I could not connect yesterday, but other players were connected with no issues. During the time when I was being disrupted from official 1742, another player saw that the server’s ping was bouncing around in a very odd, and unusual fashion.

Not sure if they are related at all. But if your server is hosted on g-portal, and/or if your route goes through Atlanta, GA, this may be related to issues that I am having.

I’m located in Norway and my service provider is Nextgentel.
Yes the server is hosted through g-portal.

One of the admins was saying yesterday that the server RAM was going through the roof.
I don’t know if it goes through Atlanta GA, do you know how I can find that out?

It does sound like the most likely scenario that there is something with the route.

Hmm. No idea about servers that are setup for other regions (like EU). I haven’t the foggiest idea how g-portal organizes their data centers (if they have data centers over in EU, etc.). I only mention Atlanta and asked about your ISP because I was informed about an outage with my carrier near the Atlanta airport.

The server I play on is US hosted, so it might be related,
I’m just at a loss right now about what to do.
I have been able to get on after going through a lot of hassle, but its so much work that by the time I get on I don’t feel like playing any more.

1 Like

Just report it using their server reporting tool. It’s the best we can do, I suppose:

Seeing as this is only for official servers this would do me no good as it’s a private server.
I already talked with the server admin and they can find nothing wrong on their end, and everyone else is able to connect.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.