Zero Hit Points?

Game mode: [Online private, modded]
Type of issue: [Bug]
Server type: [PvE]
Region: [EU]

As can be seen in the following picture, the freshly placed vertical elevator has zero hit Points, and thus cannot be picked up again.

At first I noticed this with items from the Emberlight mod, but Emberlight items tend to have English names, and as you can also see from the picture, the elevator retained its German Designation, and thus is probably not affected by Emberlight.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. place a vertical elevator
  2. try to pick it up again and notice that the option is grayed out
  3. use a repair hammer to check for damage
1 Like

Could be another mod messing this up.

As far as I can tell in the dev kit, everything looks fine. I know what most commonly causes this error, and that error isn’t in the dev kit (and the health values show correct in the play window).

1 Like

I think it’s mod related, used different elevators these last days, ever with some mods, and had not issue at all to pick them up again.

But only tested on singleplayer these days, so not sure about servers right now.

As I wrote, I have Emberlight running on that server, so it is quite possible that Emberlight is responsible.
The other two mods are your’s @Multigun :wink:

Well jeeze, thanks for making me panic for a minute :stuck_out_tongue: But no, it’s not on my end either in that regard.

1 Like

zen, i run them to, and all is doing fine ! :sweat_smile:

I don’t have emberlight, however I do use pickup+ and I noticed I can’t always pick things up again. However HP of item was what it should be. The items I can’t pickup seem totally random. I am just wondering if I have a similar issue, do you have this issue with anything else other than elevators?

Such a bug existed for some time for a Folding Screen: you had to repair it before picking up 'cause it had nill or even negative hit points.

There ar some Emberlight items with zero hit points in my castle, and i cannot pick them up again, though this was possible before.

It is not possible to repair these Emberllight items, there are no materials mentioned in the repair dialogue.

The elevator shows no material needs to repair it, look at the picture. I can hit it as much as I want, having iron and shaped Wood with me, it does not get a single hit point.

Would you please go to the Emberlight discord channel and report this bug? Those guys are very responsive, they eliminate their bugs very quickly if they find them (or tell which other mod can cause it).

1 Like

I do not use discord (yet), but I have sent a PM to the modders :wink:

1 Like

Emberlight modder wrote that this is a base game error, as they never touched the elevators.

They know of this, but thus far are unable to circumvent it for their own items…

Online private, modded with Pippi and AoC
Western Europe

After placing elevator, HP of elevator is 0 (zero). Unable to repair with repair hammer.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Craft elevator
  2. Place elevator on building
  3. Use repair hammer to see HP, which is now 0.
  4. Try to repair elevator, unsuccessful.
1 Like

Merging thread with a similar issue into this one.
@Scuga, is the server you’re playing on modded?

Sorry, yes!

We are running both Pippi and AoC.

It seems that this issue could be caused by some mod, as other people have reported.
We tried to reproduce this issue internally and elevators looked fine on our end.

1 Like

Hmm ok. Just odd that the same symptoms are triggered by different mods! I will test on a server that is not modded, and report back.

1 Like

Please let us know if this issue still happens in an unmodded game.

Just testet on server without mods., no issue. With Pippi as only mod, no issue. With AoC the elevator resets to 0 HP.