Deadlock: (also known as hang or hard freeze) Possible association with location polling

Perfect. Make four changes, please.

Wait for Vertical Refresh: Disabled
Surface Format Optimization: Disabled
Tessellation Mode: Disabled
Issue Detection: Disabled

Tessellation is the one I’m most interested in, as it can gate FPS. Issue Detection is a long shot, in case their “error reporting” system might have a bad registry entry.

Ensure you’re not enforcing FPS in the settings.

ETA: I would proceed with BattlEye before changing these GPU traits, to keep it more scientific.

2 Likes

Thank you for the advice.
We’ll find out what happens.

3 Likes

Turning off Battleye not limit your available servers?I think you cant log on

It does not trouble me because I do not play on official servers.

For the past couple of days, I limited my time to playing the game for a couple of hours per session. Everything seemed to be running stable, until this morning as I’ve been on about 4 hours.
As I had my character standing outside my new home base, just looking over the water at Riversend, the system unexpectedly and without warning, once again, went into hard lock.
As typical for what ever programming conflict is causing this, I had no choice but to power down and reboot.

I appreciate that you folks tried to help, for your advice and suggestions. But as of right now, I don’t know what else you can possibly do. This is beyond you. This is beyond common “fixes”.
I’ve lost hope in this and I have no faith left.

Was that just without BattlEye, or did you also try the four changes @Barnes suggested? Also, did you happen to try pressing Win+L when the game froze?

I tried everything.
Then only thing I could do was power down and reboot.
It was a deadlock.

Symptoms of a PC deadlock condition:
“A common symptom of deadlock is that the program or group of threads stops responding . This is also known as a hang. At least two threads are waiting for a variable that the other thread locked. The threads do not proceed, because neither thread will release its variable until it gets the other variable”.
(This is a common cause, but not exclusive).

For example:
Conan experiences a hang condition. Windows attempts to make a report of it, but is prevented by the hang condition and results in a dual hang condition. On a guess, the condition cascades.

So, my character is idle (except for looking around) and out of the clear blue, the whole system locks up. So it begs the question of what could possibly be going on in the background that might cause this to happen?

The first thing that comes to mind is “polling”.

Your position in the game world is clearly one of those variables. It must be checked often, if not constantly.
If not associated with lag, it can be a cause of “rubber banding”.
I am certain you have seen and read those complaints, probably more than you want to count. Often attributed to and blamed on : bad internet, distance, hardware, “potato”, graphics, etc, etc …
even localized rubber banding because of an object that isn’t supposed to be there (because it was mined), but finding one’s self rubber banding at that very spot where the object once was.
It’s a lot more “wide spread” than you can imagine.
The more I think about it as it has happened before, the game has to poll your position in the world (how often, I don’t know). But it is a “vital” necessary function to determine your position in the world and keep track of it. But thinking back to several occasions this happened, I recall specifically times when I found myself somewhere else other than where I was when the deadlock occurred. Most notably is when I’ve been on the move.
(i.e.) I was on the roof doing some work (in game of course) when the system goes into deadlock. When I get back in the game, I found myself on the ground about 20 meters away from the building. But, that was my last position before I went up on the roof. That’s a time span of about 5 minutes lost. Here’s the kicker;
I’m still carrying the materials I had while I was up on the roof. But I didn’t have those materials before I went up on the roof. (That’s a related issue but not specific to location memory).
This isn’t the first time this “glitch” in the game engine with remembering where I am in the game world. Far from the first time. It’s been the majority of occurrences when I find myself somewhere else other than where I am supposed to be when the event occurred and often with hostile and fatal results for my character.
But I also remember this happening way back during early access, but often when that happened, it was a lot worse.
Such as this occurrence: I’m running toward the Dafari Camp near the Dregs from above them on the escarpment and nearing the path leading down to the river’s edge, when suddenly the system goes into Deadlock. When I get back into game, I found myself clear across the ravine and across the river up standing on the cliff face a few hundred meters away. Granted, a little lower than was my last known position opposite of where the deadlock occurred. (ballistic physics speaking)
But this very same thing happened recently out near the “Pit”. I was on the ledge near “The Summoning Place” when Deadlock happens, and when I get back I find myself surrounded by undead hyenas and I’m chewed to death near the drop off into the pit a few hundred meters away from where I was before the deadlock. But that wasn’t where I was before I got to the ledge near the Summoning Place. I had not even passed near the pit.

Seriously, this issue isn’t new. As I said, it’s an ongoing issue and it’s been around a long time. A lot longer than anybody wants to admit.

“Polling”.

Look into that.

That’s programming and it’s not my department.

Maybe this happens to me more than most others, perhaps because my system is less “Fault Tolerant”.

After recovering from yesterday’s disappointment, I log into the game this morning. Remembering where I was when the system went into Deadlock.

Instead of being at my last location (outside, on the porch) looking over the water at Riversend, I find myself in the house standing on the staircase in between floors.
(where I once was before going outside).

Just to add data - I’ve been getting quite a lot of freeze-ups/crashes recently (though not experiencing the full deadlock - I am always able to access task manager - and then usually get a message that ConanSandbox.exe has stopped working). Whenever I log back in afterwards I am also in a different location from when the crash occurred (usually only a matter of 10-20 metres). What is odd is that several of these crashes recently have involved equipping/unequipping armor to a particular thrall, and I have generally reappeared back where I was when I picked up the armor from a chest, but the first piece transferred (which triggers the crash) has already successfully transferred onto the thrall. So I have both gone back in time and not gone back in time…

1 Like

I just want to offer a quick explanation for anyone who is wondering why they’re not in the same location where they were before their game froze up or crashed.

The way most of the modern multiplayer games like Conan Exiles work is that the client is responsible for three things, basically:

  • receiving the state of the world from the server
    • the state does not include things that are completely static and immutable, like terrain
    • the state does include your character
    • the state does not encompass the whole map, only the part that is close enough to you to matter
  • rendering that state on your screen and your audio device
  • telling the server about your “inputs”, e.g. that you’re moving forward while strafing left, or that you interacted with the door, or that you’re executing a light attack with your axe

Sounds simple, but there’s a couple of things to keep in mind that aren’t necessarily obvious or intuitive if you don’t know how things work:

  • The client will keep rendering the state it has until it gets an update from the server.
    • If that update contradicts what the client “knows”, the client will have to adjust
  • The server will keep simulating the last input it received from the client until the client sends different input or disconnects.

These two things explain many of WTFs people see in the game. Rubberbanding is what you get when the client can’t talk to the server smoothly enough or fast enough, so the client keeps having to correct what it “knows” about the state of the world. Scorpions slowly levitating into the sky is what you get when an update for those scorpions never gets from the server to your client.

And it also explains why you find yourself far from where you were when you disconnected. Due to how the networks actually work, if your client crashes, it cannot “hang up” its connection to the server properly and it takes some time for the server to realize the client isn’t there anymore.

So if the last input the client sent to the server, before crashing, was “my player’s character is moving forward”, the server will keep moving you forward, waiting for the client to give it your next input, until it realizes that the client is not there anymore. Only then will it log you out of the game.

I hope this clarified why some things happen.

I also hope it clarified that there’s no “polling” involved. Polling is really not a good way for games like this to work. Instead, client and server are sending each other messages.

While we’re on the subject of tech lingo, “deadlock” has a specific meaning – the one you quoted from Microsoft’s docs for software devs – but it’s important to understand that it does not mean “my computer froze”.

Not every deadlock will cause your computer to completely stop responding, and vice versa, your computer might stop responding for reasons other than deadlock. The focus of anyone trying to diagnose your problem should be on why it causes your whole computer to become completely unresponsive, rather than just your game. My intuition is that it’s because something bad happens on a very low level, with very high privileges, which is not a level Conan Exiles runs at.

If I’m right, that doesn’t mean that Conan Exiles isn’t causing it indirectly, but it does mean that the code that’s running when your computer freezes is not Conan Exiles code.

For an overview of what I’m talking about, you can take a look at the Wikipedia entry on protection rings. Suffice it to say that Conan Exiles, as a game, does not have the privilege to make your computer stop responding completely. It has to be something either in the operating system itself, or the drivers, or the anti-cheat software. The trick is finding what combination of factors is causing that, and it’s devilishly hard.

4 Likes

confirmed, I’ve experienced those for the first time in latest live build, in regular gameplay anyway
I crash things when modding on a different level

2 Likes

I would think that if the code issue were Windows exclusive, it wouldn’t matter much regarding any game I would be playing as I’m almost certain the deadlock condition would happen regardless whether I was playing a game, using Blender 3D, or just browsing the internet. I had “normal” crashes when those apps just plain quit responding, but not as severe to cause Windows 10 to go into complete lockup.
I did mention where the issue began occurring while playing a different game (an MMO), but subsequent updates to Windows 10 (and most likely corresponding updates to that game) “seemed” to have corrected that as I’ve not had the issue repeat while playing that game. That’s been over two months ago.
What is happening seems to be a programming or thread conflict between Windows 10 and this game in such a way which appears to be involving player location in the game world (primarily) that my system has very little or no way of avoiding that condition when it does happen. But that’s a condition that should be avoidable.
As I’ve said before, it doesn’t matter what I’m doing (active or idle), it simply occurs random.
I know when I’m playing solo, the server is running on my machine in that aspect. I also know when I’ve played online (on a rented server), that my client and the server must communicate.
Either one either way, the condition exists as it has proven itself by affecting my system with a deadlock condition although the rented server was unaffected. So, that brings it back to my system, my Windows and exclusively Conan Exiles (and Isle of Siptah).
But it doesn’t affect just me, it seems to be affecting others in a similar manner (except that my system goes into deadlock).
When I’m idle; doing nothing. Nothing is being event driven.
But none the less, I agree. It’s devilishly hard to find it.

This post was flagged by the community and is temporarily hidden.

This post was flagged by the community and is temporarily hidden.

After decades in the help business after your previous post about polling, I figured you were intractable. @CodeMage once again amazes me by helping you get closer to the nut of this thing. This being said:

With my test machine, I can produce a hard lock by using the GPU software to enforce a frame rate target. I can’t simulate AMD Tessellation, but this feature does employ frame limiting, according to AMD. Therefore it might be a good idea to reset your GPU using the utility, then turning off all features that limit frames.

To produce my lock, it occasionally happens after the PC goes into the spinning screen saver mode while in-game. If you watch your PC, you’ll notice the FPS dropping into the 20s during the screen spin, especially if your base is populated.

1 Like

Just adding my info, I’ve had those game lockups and also computer freeze since the beggining like you say.
But I just attributed then to my old hardware back then.
Just this week when I reinstalled on a new system, I’ve been getting a lot of the game hanging and can’t call the task manager to close the proccess if the game was in fullscreen.
So indeed something is up with the game.

My old system was FX 8320E, 8 GB RAM, RX 480 4GB windows 10 home.
My current system is i5 10400F 2.90 MHz, 16 GB RAM, GTX 1660 6Gb windows 10 home.

Forgot to say, playing on testlive version with no mods, singleplayer.

1 Like

What kind of framerate are you getting from that 1660? Are you doing 1080p/60 or better?

1 Like

1080p/60.

After reading the thread and revising the configuration I was using the game frame limiter set to 60 and the game vsync, which should not be needed. I set frame uncapped and vsync, should limit to 60.
Also my monitor is gsync compatible, but not certified, I had that enabled on nvidia configs, disabled now.

I also noticed what someone said that it seens to freeze more frequently when the game enters away mode, but I’ve had freezes on the base when busy running around.

Will notice if something changes now that I had a couple settings touching frames changed, but I think it might be something to do with single player being both the server and client.

Maybe trying to run a dedicated server for single player could fix, I remember I did that once on the older PC.

1 Like

I followed your suggestions.

A deadlock occurred.
To be specific, in less than one minute of being idle and I’ve been in game about 4 hours.
Now, permit me to provide some details.
I was not AFK when it happened. I was “in” my character and simply using the mouse to look around while in 3rd person view (not vanity view). I wasn’t moving my character.
There are no thralls except for the T1 alchemist doing its thing at the bench, then there is the elephant and the horse in the barn section of the home and I could hear them. I also could hear the ambient sounds around me. It isn’t raining and I can see the trees sway in the breeze and hear the sound of it. Iron ore is being processed into iron bars in the furnace. I have music turned all the way down so I can hear the world around me. The home isn’t a city or castle, it’s not even a mansion or an estate. Just a large home with a lot of space being taken up by stations with the sleeping quarters (and artisans table) up on the second floor with the bed on a loft.

I do realize there is an extensive list of things going on to keep the game updated on where I am, what I am doing, what I hear and see, and what animations my character is programmed to execute in that moment. (shuffling, blinking, etc. The things that make the character seem “alive”). Technically speaking, you can say the character is hardly ever idle, even if standing still. Then there is also the extensive list of things that renders the world and the animated environment around me within a specific range. All that in a seemingly perfectly timed symphony and harmony.
These things are going on when the deadlock occurred, everything stopped.

I said it is unpredictable.
What part of “unpredictable” did you miss?

I have to wait and see whether or not it happens again. When it will happen is something I cannot determine. But I am fairly confident it will happen again.

I really don’t expect either one of you to divine what this issue is.
I know you’re both trying to be helpful and assist me in pinning down what is causing this. But I don’t expect either of you to be able to dig deep into the programming conflict that is causing this. Much less do I expect you to find the specific lines of code which contribute to it. That’s the developers job and from the looks of things, they’ve got their hands full with other matters.

This goes deeper than superficial common “fixes”.

I have said before, I had professionals looking into this system with the possibility of them being able to determine if something is amiss with my hardware and software. They found nothing.

Now honest to God, do you really think I’m being stubborn or stupid?
Maybe I am being stubborn.

1 Like

I play on PS4 and when this happens to me it seems like it’s related to travelling a distance and looking into a very full containter