PS4 Patch (30.01.2020) - January Patch: General, Exploit, UI, NPC and more fixes

Just for you @jot29


Wanted to go there anyway in 10mins… Now I have even more reasons too :star_struck: Thx for the video.

Killed all 4, but nothing… another time then :slight_smile:

Edit again: I just killed the demonic spider in the wine cellar dungeon and didnt get a skeleton key. @Wak4863 could you test it too?

1 Like

I signed up to agree with this statement. I rarely play because of this bug alone

1 Like

I was able to harvest a key and got an Eye of the Khan as my reward.

Also Just got my first set of Khari Daggers on official.

1 Like

Very strange. I used a pick until nothing from the spider was there anymore and even tried to open the chest, but nothing… no key.

And congratz on the daggers :slight_smile:

server latam is too bad after last update, too many lag

1 Like

Patches are always a good thing…, well, OK you know what I mean.
Just read through the notes & about to level my next thrall to 20 tonight but I have already noticed the SHIELD bug is still here. Specifically shields still do not ADD their armor to player = neither armor points nor defense stats; Ymir’s Targe does add one tick of cold protection to my 4 tick naked player (?) but neither it nor Scorpion’s Ward add any armor/defence.
Do we have info on the shield glitch?

So what’s up with named thralls now not spawning. 4 hours farming for Dalinsia in mounds now and not 1. Previously every 3ed or 4th respawn would have 1. Now not 1 and we are on 20+ respawn.

Also the rubber banding with obs is a major break.

Even with all the “fixes” that happened I am still having to wait like 10-15min for things to load and aren’t even able to move until they do…so haven’t seen any improvement on this end yet…

It wasn’t the forums one when I did it yesterday. And why is the forum trying to override what I expect my browser to do anyway!? Such crappy design.

This update is game breaking. This invisible wall pops up not only at the obilisk but at any loading screen. So loading out of the well skelos is certain death, and during pvp if you open your inventory to select a different item once exited the menu the wall is there again… Infact even after leaving a work bench or standing Stoll for a short time. Even walking through doors this happens… This needs to be fixed asap honestly game breaking stuff… These “bug fixing” updates need to be tested on console before release. Everytime the “fix something” the break the game a little more…

1 Like

Well, first impact!!! All the same, game crashes each 5 minutes, now on the obelisks we get stuck without moving. Im not sure about what you did about stability but as a customer im quite dissapointed. :frowning:

Known issues

Hey everybody,

We’re currently aware of an issue happening after using the map room or teleporting causing rubberbanding for a few seconds. We’re working on a fix which we’ll release as a part of an upcoming hotfix.
We’re also aware of an inconsistent problem with corpses killing players stating a “fall from the world” death. It is also being looked into.
Both are part of a few of the most aggressive exploit fixes we’ve released with this patch which we’ll try to fine-tune and perfect with the next hotfix.(1)

1 Like

Dear team,

i just want that your team are aware how frustating is playing the game lately. It is not only related with this update, that didnt bringed any visible performance fixes.
Me and my colleagues, we strugle to survive from other players and also from the game.

We die from nothing and we lose everything. I already died climbing a small rock.
Game crashes each 10 minutes and we lose our items because we are not able to login again in time. Sometimes it takes more then 30minutes

When someone raid us, we take more then 20minutes to spawn at our base, the same do not happen with this clan for instance and others already reported the same.

I struggle to not uninstall the game, i bought the game, the DLCS and im quite dissapointed as apparently the image that passes to us is that you dont care about official servers as your core bussiness is the private servers.

At this point most of the player dont want to spend more money because they are losing the faith on this game. To be harder then life, it is better to live and work.

Please analize the 3147 as an example because here even raid is possible out of the time. There is bases inside scenary. Many strange things going on lately.

As a customer im feeling very unpleasant because i payed for something that is not working properly and the pleasure experience of playing is becaming very unpleasant and frustrating.

Please help us enjoying the game again.

I have been stuck on the infinite loading screen for the past week. The two times I have been able to get on I am in the desert with all my gear missing. It is obvious that it is on your end as I can only login after the servers have gone down. So I can spawn in once in the morning, before work, after the server wipe and I am stuck on the infinite loading screen until the server wipe for the next day. So I can’t play after work which is when I play most of the time. Fix this ASAP.

Hi after the last patch on PS4 the lag is worst, into my own base, or going to the obelisks, the performance has going down. Please fix it, thanks!

I am having the same problems anywhere i go i start lagging really bad and get stuck in the rolling animation, its getting to be very annoying. Also another thing i cant learn any recipes or anything it shows that i do and then doesn’t show up, trying to learn Herbal tea and its not working and or not showing up. Also another thing i have to call the elevator twice now sometimes three times to get them to come down its like they are glitched out. Please fix these problems ASAP this game was fun and fine before this update just some little issues that needed fixed and now the game is almost unplayable. As a player its very saddening iv spent a lot of money on this game and now i can’t play it it sucks it really does. If its not fixed soon then imma probably not play anymore!

Thanks please fix it

1 Like

I am happy to post a little good news and say that this fix worked like a charm. I no sooner arrived at said location, then the Journey Step logged as completed! Only two to go for me now. Thankyou so much for that fix guys.

@Larathiel did you happen to notice this in the PC patch notes?


I did notice it, yes, but I’m not sure what is necessary to trigger its completion. AFAIK, I have every map symbol found on the wiki’s map, yet the step still hasn’t completed for me even after re-visiting a couple locations.

Sure hope it isn’t necessary to revisit every single one as there would be no good way to keep track of them since the symbols are already present…

Yes. When using an obelisk, I have movement issues for several seconds as if something is blocking my way (since this patch). Also, after spawning my feet are stuck in one spot until I roll a few times