TestLive Patch Notes (03.07.2018)


#1

TestLive Patch Notes (03.07.2018)

Hey all! We got a new TestLive build out so make sure to update your game. This version is 102881/18608.
Please be sure to read our post about what’s happening in the upcoming weeks here:

Patch Notes

We’ve added more control for clans in the form of hierarchy options:

  1. As a first step, we added a new “recruit” clan level, which is the default level after joining a clan.
  2. Vaults will after the patch only be accessible by clan “members”, “officers” and “guild leaders”.
  3. Recruits have to be promoted manually to a higher level in order to access vaults.

Terrain Fixes

  • Patched up holes in the towers within the volcano that previously allowed players to get inside.
  • Added building blocking near the Shrine of Oracle.
  • Patched a hollow area inside the Bridge of the Betrayer so you can no longer build inside it.
  • Fixed the terrain in The Pit so it’s no longer possible to get under it.
  • Patched up a place in the Boundary Spillway that was possible to get inside.
  • Fixed a pocket inside a mountain at “The Crevice” that could previously be built into.

Additional Notes

  • Fixed an issue where traps would remain in the air after dismantling the structure they were placed on.
  • Added sound effects for dismantling placeables and crafting stations.
  • Fixed an issue with foundations where it was possible to create a double layer of protection.
  • All Star Metal weapons should now equal Khitai weapons in durability, armor penetration and damage.
  • You will no longer get a loading screen if the wrong Direct Connect IP address is entered.
  • It was previously not possible to click the “OK” button after typing the wrong IP address and then timing out.
  • You can no longer place foundations on Lore Tablets.
  • Crocodiles will now attack when inside water.
  • Insulated Wood recipe now consists of 2 Resin, 1 Oil instead of just 1 Resin to bring the cost of Tier3 Black Ice buildings more on par with Tier3 stone buildings.
  • Obsidian weapon crafting has been revamped. Obsidian now requires Composite Obsidian to be crafted. This resource can only be crafted in the Volcanic Forge, and the recipe can be (re)learned from the end of the Volcano dungeon. Obsidian weapons can be crafted in any blacksmith bench as long as you have Composite Obsidian.
  • Functional Warpaints now properly decay over time.
  • NPCs should no longer rubberband, teleport, then hit you from far away.

If you would like these notes in German, a moderator volunteered to translated them and can be found here.


As usual, please post bug reports in the following format when possible:

Game mode: Official Testlive | Private Testlive | Singleplayer
Version: 9xxxx/1xxxx (can be read from bottom right on main menu, or at the bottom of the ingame menu)
Problem: Crash | Bug | Performance | Misc
Crash dump link (if applicable, fill out the report with your email address to receive)

[Title: relevant subject which describes the problem]

[Free text]

Repro steps:
1.
2.
3.
4.

Click here for directions on how to access TestLive.

Testlive Patch Notes (28/06/2018)

Summary

We have a new patch available on the Testlive branch for you! This will update the Khitan armors to have the right repair cost, help armorer thralls re-learn how to make Hyena Fur Armor, and fix a nasty connection bug.

  • Fixed repair-cost issue with Khitan armors
  • Fixed a balance issue for DLC building pieces
  • Walls in the Volcano dungeon should no longer be climbable
  • Updated collision on large trees to allow building nearby
  • Fence foundations should be attachable to regular Foundations and Wedge Foundations
  • Khitan Stars can now be easily upgraded to Khitan Stairs with rails
  • Fixed a bug where you couldn’t open the admin panel after opening it during an Avatar summoning
  • All kinds of Hyena Fur Armor should now be accessible
  • Fixed a bug where dropping multiple items wouldn’t combine them into one big bag
  • Fixed an issue where the Journey Step UI would reset after logging out and logging back in
  • Game now displays the correct error message when a player tries to join a co-op session while it’s closing down.
  • Fixed an issue where a thrall would disappear when moving them out of the thrall slot
  • Tethering Distance slider should no longer be grayed out in the New Game’s Custom sub-menu
  • Fixed an issue where thralls would use shields once, then never again
  • Fixed an issue where logging off after placing down a new building piece could result in an infinite loading loop

Testlive Patch Notes (25/6/2018):

Summary

Got a new build out for you all! If you’re curious when you’ll see these fixes plus the large one from last week live, as well as other plans for patches this week, please be sure to read our update here:
Patch focus this week and DLC discussions

Changelog

  • Exploit fix: Fixed collision to prevent building base inside mountain at Sillway base.
  • Exploit fix: Fixed collision to prevent building base inside mesh at Kaels Stronghold.
  • Exploit fix: Updated code to relaunch Battleye process if it gets stopped.
  • Exploit fix: Fixed an exploit related to using chairs underwater.
  • Exploit fix: Fixed collision to prevent building base inside tube like structure next to Ruins of Xullan.
  • Exploit fix: Fixed collision to prevent building base inside a tower near Priestkings Retreat.
  • Exploit fix: Fixed collision to prevent building base inside tower near the Tradeway.
  • Exploit fix: Fixed collision to prevent building base east of Black Keep/Ruins of Xullan.
  • Exploit fix: Fixed collision to prevent building base at Deserter’s Gutter tubes.
  • Fixed a case where corpses weren’t appearing upon launching the game.
  • Fixed an issue with human NPCs not facing you while attacking.
  • Fixed a problem with thralls not respawning after being dragged away and hidden.
  • Changed Purge Meter Update Frequency to Purge Meter Update Interval and updated tool tip.
  • Added a tool tip to the “Avatar Lifetime” combat server setting.
  • Fixed wrong or missing audio for several GUI elements.
  • Crocodiles now stay away from deep water.
  • Removed redundant pillars underneath the Deathwhisper Ruins location.
  • Added sound cues when browsing inventory.
  • “Cause of death” messages should now be properly localized.
  • Removed placeholder preview image which could show up when using the dye functionality from a crafting station.
  • Adjusted spawn rate for crafters on the pirate ship.
  • Crimson Lotus Powder can now be used in the grinder.
  • The climbing bonus from armor flexibility has been rebalanced.
  • Various client crash fixes.
  • Fixed a crash issue with the Purge.
  • Khitan building pieces can now be crafted from the quickbar/radial menu.
  • Llarn Steeltoe was incorrectly flagged as a T3.
  • Irniz of the Furnace now remembers how to make Epic Flawless Zamorian armor.

TestLive Patch Notes (20/6/2018)

Summary

Version: 100928/18372
Prepare your eyes, for my massive wall of text!! I do apologize for the lateness of this. The TestLive patch is currently out. These notes aren’t very pretty or organized, but we’ll be putting these onto live soon enough where we’ll certainly make them easier to read. For now, take a look at the changes made.

Threat Animations
Added threat animations for several animals to improve immersion. These will activate when you get close to the monster. This is still being worked on though, and will be updated in a hotfix soon.
Threat system known issues:

  • NPCs do not rotate towards the player they are trying to threaten
  • If an NPC has done a threat animation towards a target and entered combat it will never do a threat animation against that target again.
  • NPCs sometimes move while they are still doing threaten animations
  • NPCs are sometimes in threat animation loop for longer then they are supposed to

Additionally, there is a known issue where crafting progress can reset on a server. This will also be hotfixed!


TL;DR

  • Light Armor Journey bug is fixed!
  • The Clan Menu has been redesigned.
  • Added proper resolution scaling when in windowed fullscreen mode. In this mode, only resolutions with the same aspect ratio as the desktop resolution are available.
  • The background image on the main menu has been changed to motion graphics.
  • Durability bars are now color coded depending on the item type.
  • Fixed a problem where players could sometimes be removed from the clan between logins.
  • Human NPCs no longer get stuck after throwing one javelin/orb.
  • You can now spawn in quest items using the admin panel.
  • Garden areas in the volcano zone now apply Noxious Gas debuff.
  • Adjusting the harvest amount multiplier no longer affects how many skeleton keys you receive from bosses.
  • Fixed a bug where humanoid NPCs (including skeletons) would do more damage on you in their first attack than any other attack.
  • Shields have been adjusted and provide much more armor.
  • Much facederp removed (Unique NPC’s should no longer look as if their mother and father were brother and sister)
  • You can now mute players using the Player List.

There were a ton of other notes and things fixed internally, but these are the ones that effect your gameplay experience directly and would like to know about.

Mother of all Patch Notes

  • You can now access purge settings while playing.
  • Fixed Gui Audio during Character Creation
  • Fixed collision issue for Status of the serpents in last boss throne room in Skelos Dungeon.
  • Fixed an issue where editing the Player Idle Thirst Multiplier and Player Idle Hunger Multiplier as an admin did not save after applying changes.
  • Made the on/off switch more intuitive on crafting stations when using a controller.
  • The Clan Menu has been redesigned.
  • In the settings menu, nudity is now a dropdown option to be in line with other setting choices.
  • Optimized stamina code which improves server performance
  • Disabling laptop mode no longer requires the client to restart.
  • You can no longer activate Ansel from the main menu.
  • Fixed an issue that made it possible to regenerate stamina while climbing.
  • Placing an item on the ground will no longer trigger a basic attack animation.
  • Only first armor color slot can be selected in dye UI using mouse & keyboard.
  • Fix for purge audio playing on top of itself.
  • Fixed an issue where moving a thrall would cause it to move incredibly slowly to the new location.
  • Optimized spawn code to be more performant.
  • Added proper resolution scaling when in windowed fullscreen mode. In this mode, only resolutions with the same aspect ratio as the desktop resolution are available.
  • NPCs should now be able to attack at different elevations with reach weapons.
  • The background image on the main menu has been changed to motion graphics.
  • Swimming through water no longer causes stamina drain.
  • Messages have been altered to be more comprehensive about building restrictions during the Purge.
  • Buttons located on the left and right side of the keybindings can no longer be permanently dismissed with the controller.
  • It was previously possible to permanently dismiss almost the whole keybindings with the controller.
  • Stackable items will now merge with it’s empty stack icon on the toolbar when the toolbar is full.
  • Durability bars are now color coded depending on the item type.
  • Destroying buildings on and around corpses now causes the corpses to react correctly to the physics.
  • Nudity level now updates instantly after changing it in the server settings.
  • Loot log now correctly shows items remaining when consuming food.
  • Player can no longer drop items through walls.
  • Fixed a problem where players could sometimes be removed from the clan between logins.
  • Fixed an issue where the Witch-Queen would not retaliate when standing in a particular place in the room.
  • Modified update frequency for different actor types to improve server performance.
  • Fixed and issue with the carousel causing the game to crash.
  • Fixed an issue that when pressing the crouch button in shallow water, your character would start swimming in the air over the water.
  • Voice chat indicators no longer stop showing after respawning.
  • Your game will no longer crash when rapidly clicking the Inventory and Visceral Camera shortcuts.
  • The game will no longer crash when certain keybindings are reset with either mouse or keyboard.
  • Crashing occurred previously after switching the camera from 1st person to vanity while flying with a selected placeable object.
  • Reduced update frequency for expensive physics functions to improve server performance.
  • Planter structures previously only took 2 HP per damage from trebuchets.
  • Fixed some grass that was floating on the desert, between Dustdevil Ridge and Summoning Place.
  • Fixed an issue where your dead body would sometimes be invisible, even when standing right on the death marker.
  • A loot chest previously spawned on top of a rock in Dustdevil Ridge.
  • The “Thatched Awning” building piece’s stability now correctly decreases.
  • You should no longer hear the Witch-Queen dungeon sounds of battle outside the intended area.
  • Your character you should no longer clip into the ground textures near the Aviary.
  • 2 Handed Epic Spears now all require he spear handle as part of the recipe.
  • Patched up multiple areas you are not supposed to build in or reach.
  • Adjusted the Event Log to look more like the other menus within the main menu.
  • Fixed collision on doors in one of the house types in Sepermeru City.
  • Fixed collision on part of the Khitan Rooftop Junction.
  • Fixed weird sideways tilting of certain monsters when they moved on uneven terrain.
  • Slightly adjusted rotation rate of shellback taunt.
  • Corrected some spelling errors for the Door Frame building parts.
  • Alter of the Bat can no longer be dismantled.
  • Fixed problem with thralls swapping weapons
  • Human NPCs no longer get stuck after throwing one javelin/orb.
  • Glowing sticks no longer have fire sounds.
  • Fixed an issue where if you placed anything but a weapon in the first slot of a weapon rack, the rest of the weapons would not be displayed.
  • Weathered Skull previously had 0 HP.
  • Updated the 1st Hyrkanian bow feat and modified text.
  • Modified the Iron War Axe description so it no longer suggests that it’s made from steel.
  • Modified description on Hardened Steel Bar.
  • Updated description of The Great Sword and Obsidian Pick.
  • Water inside Deathwhisper Ruins Cave was missing water volume and effects.
  • You can now correctly learn the recipes for the Obsidian Javelin and the Obsidian Throwing Axe.
  • Armors are now set up with the right descriptors (Some had the wrong one, claiming armors were Low Grade or Mid Grade while they were in fact High Grade, etc).
  • Hot temperature debuffs adjusted slightly - removed max health penalty from them.
  • Fixed issue with curse wall near buccaneer bay that caused building issues.
  • Moved the building blocker slightly near buccaneer bay so you can now build on rock spires off the shore.
  • Fixed an issue where Ivory Horns had 0 HP upon placing.
  • The “spit emote” book is no longer located underground.
  • In wider resolutions, the map was previously centered on the left side of the screen and not centered.
  • Added a white dragon at the bottom room in the Frost Temple.
  • Changed default decay colour of food and drink
  • Toned down the amount wolves howled at night.
  • Fixed incorrectly set up damage multipliers on the Kinscourge that caused him to deal less damage than intended.
  • Fixed light attacks with Warspear of the Black Circle, which used more stamina than Heavy attacks.
  • You can now spawn in quest items using the admin panel.
  • Ladders now require less stability than before and thus can be stacked better.
  • Dying while offline will no longer respawn you in the desert with wrong hunger/thirst values.
  • Insulated Wooden Frame Foundation no longer has the same model as Stonebrick Fence Foundation.
  • The list of humanoid NPCs in Admin Panel is better sorted.
  • The sickle now correctly loses durability when you harvest plants.
  • You can now learn Serpentmen weapons from the volcano dungeon.
  • Exceptional and Flawless Hyperborean Slaver set can now be crafted.
  • Fixed issues with Serpentmen boss clipping into a wall and preventing it from attacking players.
  • Fixed an issue where hatch doors had the same HP as walls instead of doors.
  • Silent Legion armor now requires epic (perfected) paddings.
  • Fixed an issue where only two master workstations can unlock “Create Master Workstation” Journey Step.
  • Pillar lying on the ground was missing bottom texture near Flamemist Camp.
  • Damage increase from Accuracy perk 10 now correctly increases damage by 10%.
  • Yellow Lotus Potion expiration time which is now consistent with other potions.
  • Filled in gaps between textures near the North-West side of The Unnamed City.
  • Stone throwing axes can now be crafted from your inventory.
  • “Invalid Placement” text was previously difficult to see against snowy ground.
  • A crafting station side-bar has been added for the Tower of the Bats.
  • You can no longer control your character during the ending cinematic and walk through the Cursed Wall.
  • Fog from the environment behind the Portal at Altar of the Bat was showing through the portal.
  • Combat Music no longer persists after combat with non-killable NPC or Dragging an unconscious NPC.
  • The Shining Trapezohedron can be harvested from the Degenerate now.
  • Some of the green crystals could previously not be harvested in “The Passage”.
  • You can no longer build in previously buildable NPC camps.
  • Moved DesertCooking book so it cannot be build over.
  • Enemies no longer lose aggro when the user sits on a chair with armrests.
  • Fixed collision in Black Hand Camps that was missing from one side.
  • Fixed positioning for Rasmajournals that were hovering and covered by ground.
  • Chests are harder to break. They broke too easily before if accidentally hit during a fight.
  • The chest behind the snake boss in The Unnamed City now gives legendary loot.
  • Brimstone can now be harvested with multi-tool.
  • Fixed controls when climbing under a ceiling.
  • Added sounds for sliding ice chunks.
  • Armor penetration kit bonus was lowered from 15% bonus armor penetration to 5%.
  • Added missing fragment of cobblestone floor in ‘The Unnamed City’.
  • Adjusted quality for the standing torch particle effect.
  • A tree was clipping into a rock near the Descend of Dragon area.
  • Collision for dragons has been improved.
  • Cinematic events are no longer triggered from far distances.
  • Adjusted a visual where the seamline was visible on the north-east quarter of in-game world.
  • Fixed a case where ghostly wind sound looped constantly and would not stop.
  • A rock inside The Well of Skelos dungeon had misaligned collision.
  • Fixed a case where some placeables could be interacted with if you were not the owner and should not be able to.
  • You can now craft Obsidian Tools in the Volcanic Forge.
  • Fixed an issue where you could not open a map upon exiting to the Main Menu when any Avatar is summoned and re-joining it.
  • Fixed cases where Exile NPCs would wield weapons and shields when either out of combat or in idle state.
  • Fixed collision on various mountains when climbing them.
  • Serpentman would sometimes shoot with swords when away from said enemy.
  • Craft All button was previously inactive if you had resources for 1 or 10 items.
  • Religion Tools had inconsistent labels. For example, the Yog Cleaver is labelled ‘Tool’, however Blessed Yog Cleaver is labelled ‘Weapon’.
  • Fixed a case where using the Extended Leap perk would limit your interaction and attack ability.
  • Extremely Cold debuff reduced maximum health by 40 instead of 50.
  • Subtitles in the opening cinematic were off-sync.
  • Fixed rock mesh from Hanuman’s Grotto which could be seen sticking out from the sand.
  • Fixed a case where the trebuchet’s inventory could not be accessed.
  • Adjusted terrain surrounding a tower near tradeway that allowed bedrolls inside it.
  • Fixed an issue where bombs would roll and explode/damage both where they stop and where they started.
  • Optimized camera state machine to reduce overhead on dedicated servers.
  • Collision for plants in the planters have been removed.
  • Added water volumes to the shallow water in the swamp tunnel.
  • Wight creatures no longer spawn in clumped up.
  • Non human NPCs no longer ignore players in The Passage cave.
  • Weight of the Dragonbone throwing axe has been reduced.
  • Thugra has been given an actual weapon to fight with.
  • Fixed a bug where you could clip through a rock on Southern Desert Area.
  • Much facederp removed (Unique NPC’s should no longer look as if their mother and father were brother and sister).
  • Exceptional Nordheimer Armors recipes no longer missing from armorer’s bench with a tier 3 Nordheimer armorer attached.
  • Fixed Vocals for wheel of pain.
  • Black Hand Tent - Lateen can be placed on the ground correctly.
  • Crafting Complete GUI sounds were annoying over time. They are lowered in volume and have distinct but subtle differences depending on crafting category.
  • The cave entrance to Warren of Degenerates can no longer be blocked off.
  • When using a controller, there was an issue where you were no longer able to navigate the main menu if the wrong password was entered in.
  • You can no longer sit in a chair that someone else is already sitting in. Get a room, you two!
  • Fixed a bug where an NPC would attack a player sitting on a chair, but the chair would be destroyed leaving you stuck in a sitting emote.
  • Fixed some floating rocks in The Unnamed City.
  • Fixed a bug where using a Keystone while a clan leader could break the ending cinematic.
  • Greater Wheel of Pain feat no longer requires the Master Craftsman feat.
  • Garden areas in the volcano zone now apply Noxious Gas debuff.
  • Black Ice pickaxe showed wrong requirements in the UI.
  • It was previously very easy to destroy mini-boss loot chests by accident and not get the rewards.
  • Changed some ingredients required to craft certain Religion Tools.
  • Tent-mending NPC in Raider’s Ridge was previously suspended in the air.
  • Hyena armor now increases temperature by +8, rather than +10.
  • Updated the Stats Menu, where the lower part of the effects text was cut off.
  • Adjusted collision with masks inside the Palace of the Witch Queen.
  • Fixed a case where newly created character VO was inaudible if no Voice option was been chosen by the player.
  • Adjusting the harvest amount multiplier no longer affects how many skeleton keys you receive from bosses.
  • Fixed a bug where humanoid NPCs (including skeletons) would do more damage on you in their first attack than any other attack.
  • Shields have been adjusted and provide much more armor.
  • Fixed audio on young animals since they were silent when players hit them. You monster.
  • Dancers in Conan’s Tavern no longer drop loot.
  • Patched up meshes in the Frozen North and Highlands that could previously be built inside of.
  • Fixed a bug where you could join a server from the main menu if it was previously highlighted.
  • Fixed collision on branches of large trees.
  • Fixed multiple floating objects in the Flotsam camp (heh).
  • Fixed a bug where the letter in The Unnamed City instantly closed.
  • Weight values of Baal-pteor’s items were inconsistent.
  • It was previously possible to use a shield with Dragonbone Spear, Maul and Two-handed Sword.
  • Dragonbone items’ claimed that dragons do not breathe fire, though the Red Dragon clearly does. The text has been changed to reflect this.
  • It was previously possible to shoot at the Abyssal Remnant without activating the boss.
  • Glowing Wall Torch now provides temperature bonus.
  • The Emote Fistpunch book is no longer located underground.
  • Eat & drink items now play sound when you use them.
  • The Volcano flowers now give resources.
  • Spikes no longer have 0 HP upon placing.
  • Vanir armor now grants improved frost-resistance.
  • Cooling down/Warming up effects from drinks and food has been increased in efficiency.
  • Added missing waterflow sound effects by the river in Oasis.
  • NPCs were previously located in an inaccessible building in Sepermeru.
  • Moved Thrall Priest on Altar of Set ontop of the altar, instead of being submerged in it.
  • Fixed an issue where “Get Dedicated Weapon” achievement would not trigger in all localizations.
  • Two tents in the Skulker’s End were previously placed in the air.
  • Dye would previously not work on radium gem wall torch.
  • Buffs in inventory seemed to appear inner than the window border.
  • Razma’s looks are now consistent throughout the game.
  • Grass is no longer growing underwater at the far north-east of the swamp area.
  • Most weapon-recipes now grant the “Craft Weapon” journeystep instead of only select primitive weapons.
  • The Pagoda area now have more lemurians with an increased amount of priests and crafters available.
  • The food poisoning buff now has a reduced duration and does damage more rarely, giving some time to heal between each tick.
  • Human archers in the volcano now wield Falcatas instead of stone swords.
  • Mask of the Witch Queen can now be looted from the Witch Queen’s corpse.
  • Patched up an open seam in the landscape at The Ruined Outpost.
  • Fixed textures on the cobblestone floor in ‘The Well of Skelos’.
  • Adjusted the LOD distance for the spooky trees in the Shattered Springs area.
  • Fixed an issue where some Insect nests were hovering off the ground.
  • Fixed a bug where the Alpha Snake would not aggro the user and couldn’t be harvested.
  • Updated and hooked up different animation for climb up from ledges.
  • The Witch Queen can no longer be knocked unconscious.
  • Skinning Knife now gives less hide when used on human NPCs.
  • Fixed a bug where Avatar heads (Mitra, Derketo) got stuck looking sideways at random directions.
  • The sandstorm now has sound.
  • The Witch Queen can no longer be killed by her Statues.
  • Maximum encumbrance value does now updates correctly after resetting all attributes while the Attributes menu is open.
  • Fixed a bug where no religion name would show in character creation.
  • Religious tools from temples no longer give Manifestations of Zeals when crafted.
  • Journeyman Roofer feat now requires Apprentice roofer feat.
  • Fixed some spawn issues with purge NPCs
  • Fixed an issue where your Skeleton Key would be consumed every time you interacted with a Legendary Chest, whether it was opening OR closing.
  • Some of the purge areas have been tweaked.
  • Nordheimers now spawn more reliably during a purge.
  • Health values for the Rocknose King Molten and Boss have been balanced.
  • Bonuses from the Relic Hunter armor have been balanced.
  • Ragdoll on bound thralls has been adjusted and looks better.
  • You can now die from jumping into the lava pools in the volcano dungeon.
  • Fixed a bug where the magical barrier around the Volcano Dungeon boss was climbable.
  • Sandstorm Breathing Mask and Setite Mask now grant temperature bonus.
  • Compost Heap crafting guide no longer present in Altar of the Bat GUI.
  • Increased bonuses from temperature foods.
  • Lessened the effect of the cripple from 0.9 to 0.3.
  • Glowing Essence must now be crafted from the Firebowl Cauldron.
  • Collision from the top part of the Throne in the Witch Queen boss room has been fixed.
  • You are not able to block hits with a building brush anymore.
  • You can now mute players using the Player List.
  • All cinematic events now have 3D sound instead of 2D sound

Patch Schedule for this week
Patch focus this week and DLC discussions
Testlive [Version 100794/18352] Patch Notes (18.06.2018)
Irniz of the Furnace not showing her recipes on Improved Armorers bench
Relic Hunter Named Armorers missing/gliched
Patch Plans Week 2nd of July
Weekly Community Newsletter: Summer in the City
Epic Khitan heavy repairs WTF?
[German] TestLive Notes [03.07.2018]
PC - Equip Light Armor Bug
Weekly Community Newsletter: Recaps and More
What are the stats on Star Metal and Khitan weapons after TestLive Patch (03.07.2018)?
#4

First!!!

Can’t wait to try this


#5

No balance pass on vaults/trebs/explosives or not included in the notes? :thinking::thinking::thinking:


#6

so , what about the bug that purges starts and get defeated in seconds? (obviously not starting) …

what about the named Thralls that are supposed to spawn during purges in volcano areas (they dont) , and north (nordheimers (they dont) , and jungle (they dont?) …


#7

No fix for this?


#9

Game mode: Singleplayer
Version: 100928/18372
Problem: Bug

  1. Everything that eats a character has the sound of drinking water
  2. Crocodile does not attack in deep water
  3. Sandstone ramps are too long and always stick out of the floor and ceiling
  4. After death, the heartbeat is looped and the life bar is 100% ( rebirth only in the desert, then this is the error )
  5. Diagonal decorative beam does not enhance structural integrity in conjunction with Vertical decorative beam, so also shows a repair hammer.
  6. For the element, Right-sloping inverted sandstone wall you can not attach right-sloping sandstone wall structural integrity 80. The reverse left set works without problem.
  7. The problem with the well of water, I ran half of the map and it can not be set anywhere, I still get an ovrlapping message :frowning: Large does not get this message
  8. The view of the character in the inventory disappears
  9. Every time you load the game, the stations, boxes and other things disappear randomly, you have to combine and load older savegames :frowning:

I think I have enough to do the work of programmers and Dev for free :frowning:

edition open for later …

Repro steps:

  1. start the game and play :slight_smile:

#10

It does say somewhere in there - NPCs were previously located in an inaccessible building in Sepermeru.

I guess it means it’ll be fixed too


#11

So it does. I must have missed that in the too long wall of text.


#12

Nordheimers now spawn more reliably during a purge.
Some of the purge areas have been tweaked.
Fixed some spawn issues with purge NPCs


#14

Game mode: Singleplayer
Version: 100928/18372
Problem: Pagoda Camp still doesn’t have

There is no spawning of Smelter and Alchemist in Pagoda Camp

but Cook / Armorer have 2 spawning places. (one should be changed to Smelter / Alchemist)

and Volcano area still doesn’t have some type of station thralls (smelter / armorer / carpenter etc) not spawning including entertainer


#15

Game mode: Singleplayer
Version: 100928/18372
Problem: Derketo

The t3 alter of Derketo still doesn’t have its own light beam and no mark on the map


#16

I thought the Light Armor journey step bug was supposed to be fixed in this patch, but I don’t see it in the patch notes?

Also, does this fix the missing Flawless Epic armor sets on named armorers?


#17

Game mode: Official Testlive
Version: 100928/18372
Problem: Bug

Title: Journey Step Progress Appears to reset after logging out and back in.

The Journey Step log on both the UI and in the Journey Step menu show that all of your progress is reset after you logout and back in. It appears to just be the visual progress on UI though. The journey log in upper right hand part of the screen reverts to: Climb, Eat, Drink and the Journey step menu shows everything incomplete and blacked out. However, all of the previous steps you completed are still flagged completed and you do not get XP again. You still get credit for completing uncompleted steps. It just doesn’t display the new progress.
I recreated my character and tested this again. I lost visual progress of my journey steps by logging out and back in again.

Repro steps:

  1. Create a character
  2. Complete some Journey steps
  3. Logout and then log back in
  4. Observe that your visual progress has been reset, but the completed/uncompleted steps are still flagged correctly in the backend.

#18

Game mode: Testlive Singleplayer
Version: 100928/18372
Problem: Bug

Loaded in to game in foundations and missing Gates and Drawbridges.

Logged in to the game to find my character was standing on the ground in my base. The area this happened in is about 1.5 foundations deep as part of the grid pattern my base is built on and to level the ground.


Me inside the gap between foundations… I also found 1 thrall that was standing on a seam between foundations had sunk up to his shoulders.


This is near where i logged out last and the gates were there. I checked and i am missing several T2 and T3 gates, T3 Drawbridges, several totems, and a trebuchet. Everything else with the quick check was good. As I was running around, I did notice all of my dancers were not dancing.


#20

When is this going to be on ps4


#21

Singleplayer

Logged in, doors, cauldron, and dryer were gone (with loot bags). Replaced them, restarted, and they broke again. Restarted yet again without replacing them, and the tannery disappeared. IIRC, that’s the reverse order they were placed in.

Bloodstains on character aren’t going away now.

Razma is still naked. Or since her face was fixed, I guess this is intended?

Oh, and there’s still one bit of flying grass in the ostrich area by the Summoning Place.


#22

Yes Razma’s intended to be naked I believe, but only the devs know for sure.


#23

People sometimes have to move their heads a little :slight_smile:
In order for the patch to surprise and avoid errors accumulated during the game, after installing and launching you have to close the game and read the savegame from before installing the patch. The current record is “game.db” we delete it and its name is given to one of the copies. Now you should have everything as it should be, including what has been lost to you.


#24

Yea, I have the backups, the problem is that the most recent objects break after restarting. Even things placed after patch.


#25

Didn’t see anything about Crimson Lotus Flower not harvesting with a sickle or grinding into Powder in the Grinder. I’m on PC.